User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: vectra 1.9 cdti problems please look and advise

  1. #1
    New Member
    Join Date
    Jun 2010
    Location
    crewe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default vectra 1.9 cdti problems please look and advise

    hi my sister has a vectra 1.9cdti 120 it lost power and spits black smoke out all time.had it serviced and then engine light came on.

    vauxhall sed its the gas recirculation valve and the glo plugs.

    whats a grv.

    any ideas as to y it smokes whenever the accelerator is pressed.

    any help would be amazing thank you

  2. #2
    Regular Member Grumpy1954's Avatar
    Join Date
    Mar 2010
    Location
    Newport (Shropshire)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Ford Kuga

    Trim : Titanium

    Engine : 2.0dtci

    Year : 2014

    Mileage : 1200

    Default

    It's the EGR valve, not sure where it is on 120bhp. will need good clean up, may have the dreaded 3rd injector trouble, again, nothing serious. The dealer have fixes for both, or if you check the "how to's" or search for the faults on this website you'll get loads of info on this

  3. #3
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    EGR valve is what I think you mean. Exhaust gas recirculation

    (look I have all the keys on my keyboard )
    Now I need a turbo to keep up!

  4. #4
    Regular Member barney490's Avatar
    Join Date
    Dec 2009
    Location
    PRESTON
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    not sure why they said glow plugs, as these are only used on start up below a certian temperature. on a 120 the egr valve is in a similar position to a 150, at the back of the engine, top right. I'm assuming its stuck open and this is giving the black smoke, somebody may correct me on that. I replaced the egr on my 120 and they arent too bad to change, so long as you have got a set of torx bits. Its advisable to clean the boost sensor while you have the egr removed, thats the little black box to the left of the egr.

  5. #5
    Regular Member DaveW555's Avatar
    Join Date
    Apr 2010
    Location
    Cannock
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Strip the EGR out (about 10 mins work) and give it a thorough clean through with some paraffin or carb cleaner or the like, refit with a new gasket and should solve the problem.

  6. #6
    Regular Member rec's Avatar
    Join Date
    Jan 2010
    Location
    Bradford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    does it feel down on power mate? or lumpy when driving?

    sounds like my estate when we got it, everyone said EGR, 3rd injector wiring etc etc it was none of that, it was the injectors themselves that had packed up.

    had to get 3 changed, £250 each from Vauxhall!!!! now runs like a dream

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help!!! Vectra c 1.9 cdti sri 150 problems!!!!!!!
    By rajakay2010 in forum Engine & Drivetrain
    Replies: 26
    Last Post: 14th June 2012, 21:59
  2. 06 vectra 1.8 sri clutch/gearbox problems, please advise.
    By 06sri in forum Engine & Drivetrain
    Replies: 9
    Last Post: 31st May 2012, 16:30
  3. Problems Vectra 1.9 cdti 150
    By Portugalvectracdti in forum Introduce yourself.
    Replies: 0
    Last Post: 19th January 2011, 11:46
  4. vectra c 120 cdti sri problems
    By paulf in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 23rd November 2009, 23:52

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •