User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Whiny A/C Compressor

  1. #1
    Regular Member AntB's Avatar
    Join Date
    Sep 2007
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats


    Trim : GSi

    Engine : 3.2 V6


    Mileage : 39k

    Default Whiny A/C Compressor

    OK, whenever I put my foot down with the air-con on, especially when setting off, the compressor makes a horrid whiny, wailing noise which increases with speed. It's at it's loudest around 2.5k revs then drops off from there. If I turn the air-con off, the noise stops.

    I use the air-con all year round & it's usually silent, it only seems to make a noise in the hot weather, I guess the compressor is under more strain.

    I took it to Kwikfit last summer (it was noisy then, too) for a gas check/refill as it was getting cold, but not exactly frosty, especially when the car wasn't on the move. They hooked it up to their monkey proof machine & said all was fine, just required topping up slightly, but nothing they wouldn't expect to see from a car of it's age.

    So, the question is, is the compressor on it's last legs? Would a new compressor mean better cooling?

    OK, that was two questions, but any help/advice would be appreciated. It's still got a few months warranty left so if it is faulty I can (hopefully) get it sorted along with the duff recirc servo.

  2. #2
    Regular Member DarylAAS's Avatar
    Join Date
    Apr 2010
    Location
    South Shields
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi Mate,
    Compressors Are usually noisier in the warmer weather as there under more strain... and your aircon not being frosty is usually because it hasnt got as much gas in as it should... i usually add a bit more than recomended so its as cold as possible...
    HTH

  3. #3
    Regular Member AntB's Avatar
    Join Date
    Sep 2007
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats


    Trim : GSi

    Engine : 3.2 V6


    Mileage : 39k

    Default

    Ah, so nothing to worry about, compressor wise? As for the low gas, that's what I thought last year when I took it to Kwikfit, the top-up/refill/whatever they did made little to no difference.

    Maybe the system just isn't up to my expectations; it cools fine when at motorway speeds, less so at 30 & under, and what seems barley cool when stationary.

    Is anyone else's the same or do I have a fault elsewhere on the system?

  4. #4
    Regular Member
    Join Date
    Oct 2007
    Location
    Shropshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mine is icey cold when stationary, just takes about 1/2"hour to get that cold!

  5. #5
    Regular Member axelf's Avatar
    Join Date
    May 2009
    Location
    chester le street
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It sounds like we have the same problem...i am havin a trip to see Daryl to see if a topup fixes the whining.....will keep you posted....

  6. #6
    Regular Member watchman's Avatar
    Join Date
    Apr 2009
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : Z28NET

    Year : 2007

    Mileage : 75000

    Default

    I had mine into KwikFit a couple of weeks ago as it basically wasn't having any effect at all.
    Big difference afterwards - much cooler.
    But now the compressor is much noisier.
    I assumed that was a sign that it was actually working.

  7. #7
    Regular Member Exclusive BV's Avatar
    Join Date
    Apr 2010
    Location
    West Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yeah mine aswell. whoosh whine silent...........whoosh whine etc...

    It cools not too bad when it's warmed up (you know what I mean )

    The thing is you can only hear the sounds inside the car, standing outside, the car sounds normal apart from the odd click from the relays when the comp kicks in

  8. #8
    Regular Member AntB's Avatar
    Join Date
    Sep 2007
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats


    Trim : GSi

    Engine : 3.2 V6


    Mileage : 39k

    Default

    Bump.

    Now the weather is hot again the noise is back and I've had a thought. I get the quite common "chirp" sound from the AUX belt, more often when it's cooler & damp but it can happen any time.

    Now I know this can be related to a dodgy belt tensioner, so, my question is: does anyone else that has the same A/C whine as me also have the occasional chirp sound from their aux belt too?

    I've read on a couple of forums where this problem turned out to be worn bearings in the tensioner, when the a/c compressor kicks in the extra strain caused it to whine and there can be belt slippage at low rpm, maybe leading to the poor cooling when sat at idle.

    Does this sound plausible to anyone else?

  9. #9
    Regular Member mozzer99's Avatar
    Join Date
    Jun 2010
    Location
    bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    the other possibility is the aircon clutch is worn and slipping.
    this is replaceable without draining/evacuating the gas. Also the bearing inside the clutch is replaceable and when it's on the way out it will make a considerable noise (although it will do that all of the time as it is under load from the belt full time).

  10. #10
    Regular Member
    Join Date
    Feb 2009
    Location
    jilava
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by AntB View Post
    Bump.

    Now the weather is hot again the noise is back and I've had a thought. I get the quite common "chirp" sound from the AUX belt, more often when it's cooler & damp but it can happen any time.

    Now I know this can be related to a dodgy belt tensioner, so, my question is: does anyone else that has the same A/C whine as me also have the occasional chirp sound from their aux belt too?

    I've read on a couple of forums where this problem turned out to be worn bearings in the tensioner, when the a/c compressor kicks in the extra strain caused it to whine and there can be belt slippage at low rpm, maybe leading to the poor cooling when sat at idle.

    Does this sound plausible to anyone else?

    No I don't have this chirp sound from the aux belt, but I do have the whining sound inside the car. Goes away imidiately if I turn the aircon off. What's buggin me is last year it did not make these sounds but was topped up with coolant in spring so maybe now it needs regasing.
    Anyone tryed regasing? what was the result?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Air Con Compressor
    By Siggy08 in forum Vectra C / Signum Car Chat
    Replies: 8
    Last Post: 28th November 2012, 15:52
  2. Air con compressor
    By keith1983 in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 28th November 2009, 19:20
  3. air compressor
    By chris1804 in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 18th November 2009, 07:56

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •