User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Squeaky 314's...

  1. #1
    Regular Member danBoy's Avatar
    Join Date
    Jun 2006
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Squeaky 314's...

    Now ever since my 314's were fitted I've been getting a strange squeaking noise, it doesn't do it all the time, and you can hear it with the window open, its not under braking as you can hear as your moving along without touching the brakes.

    Any ideas???

  2. #2
    Regular Member n_hudson's Avatar
    Join Date
    Mar 2008
    Location
    Northampton, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had a problem like this, id get it in a straight line, but if I turned a corner or touched the brakes, the noise would go, but then quickly come back... They also got really hot! It was as if they were binding (Just the drivers side).

    I copper greased everything, stripped them, cleaned them, new pads, checked for stones etc....

    With mine NOTHING would get rid of it! Then I managed to get another set from a Saab / Ford Garage on Ebay for £35 LOL. No noise anymore! LOL


    Is the drivers or passengers hotter than the other side?


    Really hope you get it sorted!

  3. #3
    Regular Member danBoy's Avatar
    Join Date
    Jun 2006
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I think its the drivers one, I remember just over a month ago coming home from work in it and the drivers side brakes seemed a tad hot. I'll have to check with Penfold and see if he had the same issue as they are from his Signum

  4. #4
    Ex-Staff Full Member John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    Check the back plates mate, one may just be touching and as the disc heats up and swells it will start to squeal

    Had this on mine

  5. #5
    Regular Member n_hudson's Avatar
    Join Date
    Mar 2008
    Location
    Northampton, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    When I had this problem, everyone was pointing to the Copper Grease issue... not enough on the back of the pads...

    However, I know for a fact that it was because the drivers side caliper piston wouldnt retract fully after braking. It got to the point where the Engine Management light would come on and put the car into safe mode. The drivers brake stank after a quick 20 minute drive and developed a large lip after a short distance.

    Even with these new calipers I have now, although they dont stick and do work fine, I think that using the old ones or not having bleed them correctly may have damaged the braking servo or something as they just dont feel much better than my old 302's and when Im at a stand still, if I keep my foot on the pedal, it gos to the floor until I pump it 3 or 4 times. Although they obviously stop me fine. LOL

  6. #6
    Regular Member Penfold101's Avatar
    Join Date
    Jul 2007
    Location
    Combination of Preston and Oxfordshire...
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Nope, they were fine when they were on mine mate...

  7. #7
    Regular Member danBoy's Avatar
    Join Date
    Jun 2006
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by n_hudson View Post
    When I had this problem, everyone was pointing to the Copper Grease issue... not enough on the back of the pads...

    However, I know for a fact that it was because the drivers side caliper piston wouldnt retract fully after braking. It got to the point where the Engine Management light would come on and put the car into safe mode. The drivers brake stank after a quick 20 minute drive and developed a large lip after a short distance.

    Even with these new calipers I have now, although they dont stick and do work fine, I think that using the old ones or not having bleed them correctly may have damaged the braking servo or something as they just dont feel much better than my old 302's and when Im at a stand still, if I keep my foot on the pedal, it gos to the floor until I pump it 3 or 4 times. Although they obviously stop me fine. LOL
    Tbh mine are working fine, I know they have no copper grease on them at all, not had any funny smells and they only appeared to have got hot just that one time.

  8. #8
    Regular Member Penfold101's Avatar
    Join Date
    Jul 2007
    Location
    Combination of Preston and Oxfordshire...
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by n_hudson View Post
    When I had this problem, everyone was pointing to the Copper Grease issue... not enough on the back of the pads...

    However, I know for a fact that it was because the drivers side caliper piston wouldnt retract fully after braking. It got to the point where the Engine Management light would come on and put the car into safe mode. The drivers brake stank after a quick 20 minute drive and developed a large lip after a short distance.

    Even with these new calipers I have now, although they dont stick and do work fine, I think that using the old ones or not having bleed them correctly may have damaged the braking servo or something as they just dont feel much better than my old 302's and when Im at a stand still, if I keep my foot on the pedal, it gos to the floor until I pump it 3 or 4 times. Although they obviously stop me fine. LOL
    It might be worth looking in to that sometime mate, as the 314's when working properly should stop you on a dime. I've never tried a set of 302's so I can't comment on the difference between the 2, but the difference between the 314 and the 285 setups was huge...

  9. #9
    Ex-Staff Full Member John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    The 302's are a massive improvement on the 285's but you are only going up another 12mm to 314's. The difference between the two wouldn't be night and day

  10. #10
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by john.robertson2 View Post
    The 302's are a massive improvement on the 285's but you are only going up another 12mm to 314's. The difference between the two wouldn't be night and day
    It's only 17mm difference from the 285s to the 302s so I'm surprised you notice a difference there either if that's your point of reference.
    Now I need a turbo to keep up!

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My new 314's
    By PeteD in forum Handling & Braking
    Replies: 20
    Last Post: 9th May 2012, 13:33
  2. 314's
    By MACVVT in forum Handling & Braking
    Replies: 11
    Last Post: 17th February 2012, 19:18
  3. For Sale: Set of 314's
    By plasma in forum Parts for sale
    Replies: 1
    Last Post: 7th July 2011, 22:19
  4. LMF and 314's
    By gtr1000 in forum Vectra C / Signum Car Chat
    Replies: 16
    Last Post: 22nd November 2008, 22:33

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •