User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: AFL headlight issue - levelling

  1. #1
    Regular Member tox's Avatar
    Join Date
    Apr 2010
    Location
    Bucharest
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : C

    Engine : Z19DT

    Year : 2005

    Default AFL headlight issue - levelling

    Hi mates!

    I'm a bit sad that my veccy raised a problem this evening. I have AFL and they used to work ok until now.

    first thing: changed the springs with sport ones, -35mm, and the fault indicator flashes now. Not a problem though, the left/right curve works ok, but they don't do the up/down test anymore. Didn't have time to go at stealers and recalibrate the sensors.

    But this time, the right xenon lightining is at maximum 2 meters in front of the car, doesn't illuminate like the left one. Check the 3 fuses for AFL/adjustments and they are fine, as far as i know on this system there are no fuses separately for levelling motors.

    I'm guessing some bracket inside the headlight popped off , because, when i start the engine, they both to the left/right test, but only the left one lights OK.

    Any suggestions ? thank you in advance

  2. #2
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It is worth checking the sensors attached to the suspension arms as I have read in the past that when people lower the car they can get snapped off if they are not disconnected when the spring etc is removed.

    There are two, one front and one rear.

    HTH
    Now I need a turbo to keep up!

  3. #3
    Regular Member tox's Avatar
    Join Date
    Apr 2010
    Location
    Bucharest
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : C

    Engine : Z19DT

    Year : 2005

    Default

    Well, the car was lowered almost 8 months ago, since then i drive with the fault flashing, but never had problems with vertical lightning until now, when all the sudden the right headlight dropped to the ground. Didn't do anything special, driving offroad or something. they worked ok, stopped the engine and then, hey, no light rising ! tried with the auto setting on, on 0 mode , start engine, and the manually start the lights, no luck.

  4. #4
    Regular Member Derek Mc's Avatar
    Join Date
    May 2010
    Location
    Sodding Typical on Sea
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sadly the AHLD sensors fail (both of mine were on the fritz in the Saab) and at Saab they were on 8 month backorder! I got fault codes P4310 and 4320 meaning both had failed. They are very much the weak-link so suggest you focus attention there initially.

    Derek

  5. #5
    Regular Member tox's Avatar
    Join Date
    Apr 2010
    Location
    Bucharest
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : C

    Engine : Z19DT

    Year : 2005

    Default

    I understand, but hence the both headlights are connected to the AFL computer, and sensors fail, isn't it supposed to let down both headlights, not just the right one ? I check the fuses also, number 10, 19 and 20 and they are fine. Didn't find separate fuses for levelling motors or something. My guess is something fails, the system should 'limp mode' the headlights, letting you drive on default levelling setup. also, when the car is not running, all lights off, i can notice that the lens from the right headlight is different angle from the left one. could be a mechanical failure inside the headlight ?

  6. #6
    Regular Member Derek Mc's Avatar
    Join Date
    May 2010
    Location
    Sodding Typical on Sea
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ahhh,,, I take your point, this sounds a bit strange I hope it is not a motor failure inside the lamp but wonder if there is a power / earth issue causing it, sorry this is a bit of an odd one not experienced this one.

  7. #7
    Regular Member tox's Avatar
    Join Date
    Apr 2010
    Location
    Bucharest
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : C

    Engine : Z19DT

    Year : 2005

    Default

    Any starting point ? I guess tech2 ... Do you know if the left / right motor is separate ? this would be logical, one motor for left/right one motor for up/down.

  8. #8
    Regular Member Derek Mc's Avatar
    Join Date
    May 2010
    Location
    Sodding Typical on Sea
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yes I do know that one both are separate and run independantly as the AHLD system on techII I have not got a tech system myself a neighbour ran my Saab but was able to get my car to wink at me side to side and all sorts,

  9. #9
    Regular Member Maxim007's Avatar
    Join Date
    Jul 2009
    Location
    Bistrita
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Incearca sa dai farul jos si sa vezi daca nu e plecat motorasul din far...cum zice colegul mai sus.....
    Cel din stanga mai are miscarile alea verticale la pornire?sau sta fix la fiecare pornire?
    Daca misca (isi ia distanta) sigur este ceva din farul drept...
    Si eu am AFL, si mie mi se pare ca nu urca vizibilitatea la faza scurta cand trec de 100 KM/H...asa cum e si normal....cica urca un pic la viteze mai mari pt a spori vizibilitatea...
    Eu nu observ treaba asta la mine...
    E facelift masina sau nu?

  10. #10
    Regular Member benny's Avatar
    Join Date
    Feb 2006
    Location
    dudley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    did you have it recalibrated when it was lowered: ???

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Headlight levelling.
    By Hyperhart in forum Electrical & ICE (including SatNav)
    Replies: 15
    Last Post: 18th February 2012, 23:17
  2. Self Levelling Headlight problem?
    By spoons in forum Vectra C / Signum Car Chat
    Replies: 24
    Last Post: 15th October 2010, 20:22
  3. Xenon Auto levelling issue (ongoing....)
    By RoddyKFC in forum Suspension, Wheels & Brakes
    Replies: 14
    Last Post: 26th February 2009, 23:39
  4. Xenon Headlights Auto Levelling Issue
    By bigstevex in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 14th June 2007, 21:14

Visitors found this page by searching for:

opel signum afl leveling problem

vectra c headlight motor fuse www.vectra-c.com

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •