User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Need advice/diagnosis re 57 plate Vectra 1.9 CDTi 150

  1. #1
    New Member
    Join Date
    Apr 2010
    Location
    Swindon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Need advice/diagnosis re 57 plate Vectra 1.9 CDTi 150

    Please help and advise.

    I have a Vectra 1.9 CDTi 150 which has done 73k miles.

    A month back I was driving on the motorway when the car/spanner light came on and I lost power, the battery light started flashing and I had to pull over. The car wouldn't start again, but after being towed 150 miles to my destination, it started OK, if a little juddery and I managed to drive 200 miles back home...

    Took it to a garage for a diagnostic check, and they reported that injectors 1 and 4 had an open circuit and they cleaned them for me. All ran well until last week - same/similar problem - the car/spanner light came on but this time I could restart the car and get it home (took 5 restarts though).

    The car has been back to the garage (same one) and they haven't found anything wrong, but they suspect the injectors "may" need replacing and I would have to take it to a Vauxhall dealer to get it fully diagnosed.

    The car is under a third party warranty (when I bought it second hand last year) and the place I got it from are reluctant to get a dealer to check it because they will just change the injectors and charge a fortune. I am taking it to them (in Blackburn 200 miles away) so their mechanics can take a look.

    I have checked the 3rd injector wiring issue - not that my engine has blue connectors and the engine number is new enough not to be affected.

    Is there anything else I need to check, or get them to check for me?

    Any advice would be helpful

    thanks

    Rich

  2. #2
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi

    Trim : XP NAV

    Engine : 1.9 CDTi 150

    Year : 2007

    Default

    Could be EGR related.

    Lots of thread on here regarding it, you can maybe diagnose this by disconnecting it and see how it runs - but this won't always work, it depends on what the fault is (if at all) with the EGR valve.

  3. #3
    New Member
    Join Date
    Apr 2010
    Location
    Swindon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks Dan,

    just been reading through the How 2 on cleaning the EGR etc - might give it a go, but a bit wary of trying...

    I'll see what they say next week and suggest that it could be EGR and get them to look. If it is, and they replace it I think I'll have a do at fitting the FIAT gasket myself...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vectra cdti 1.9 Sri 120 - 58 plate
    By allysri120 in forum Vectra C / Signum Car Chat
    Replies: 18
    Last Post: 17th December 2012, 09:20
  2. Loss of power diagnosis Vectra 1.9 CDti
    By MT82LFC in forum Engine & Drivetrain
    Replies: 9
    Last Post: 17th June 2011, 20:58
  3. Vectra CDTi Sri (150) 56 Plate
    By Phil-W- in forum Cars for sale
    Replies: 2
    Last Post: 12th February 2011, 11:30
  4. CDTI 150 Clutch noise. DIagnosis required
    By 12345 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 6th May 2009, 18:35
  5. Vectra 1.9 cdti 150 problem - diagnosis?
    By Fruit'n'nut in forum Engine & Drivetrain
    Replies: 13
    Last Post: 7th March 2009, 15:28

Visitors found this page by searching for:

57 plate vectra cdti 120 loosing power

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •