User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Power Steering Failure

  1. #1
    Regular Member Medc's Avatar
    Join Date
    Jan 2010
    Location
    Gloucestershire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Power Steering Failure

    After going through a car wash my power steering has stopped working. The error light came up and there was no power at all. Still drivable but somewhat hard etc.

    I checked the wires to the pump and confirmed that they were affected by water. I cleaned and dried the connection and retested. There is power coming to the pump but the pump no longer works.

    I had a VX chap check and reset the fault codes but this didn't fix the issue although it did clear the error light. I was therefore looking to buy a new pump, (£600+ from VX or about £150 on ebay).

    This has not been working for just over two weeks and driven daily, randomly on Saturday the power steering started working for 20 mins with a slight whining when I turned the wheel but then stopped again and hasn't worked since.

    This tells me that the pump does still work and buying a new one may not fix my issue. I have read that a tech2 session may help resolve the issue, any advise would be great.

    Thanks

  2. #2
    Regular Member
    Join Date
    May 2010
    Location
    norfolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i had a similar problem with my power steering 3 years ago , it stated making weard whining/growling noises and then packed up, i had to have it recovered from nottingham back to norfolk to my local vauxhall dealer and they replaced the pump assy under warranty as it had water getting into the unit through a poorly sealed blank connector on the front of the pump assembly, the ford at rufford where i was staying finished the unit off as every time i went through it the pump was submerged ! ive now got another problem with the power steering on it again , it keeps showing the steering symbol on start up intermittently and it does not work until i restart it.

  3. #3
    Regular Member
    Join Date
    Jun 2009
    Location
    Norwich
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Same problem... anymore light on the issue would be greatly appreciated??

  4. #4
    Regular Member Medc's Avatar
    Join Date
    Jan 2010
    Location
    Gloucestershire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I contacted my warrantee people and they suggested I take it to their garage to have some diagnostics done, unfortunately they aren't Vauxhall dealers so they managed to simply make the car worse.

    Now I have error lights for TC and brake light switch, but they did show that the pump is working but the sensor is not. It may be a CIM unit that needs replacing and that isn't covered by the warrantee and would be a Vauxhall main dealer job to Tech 2 the new unit.

    I have the car booked in with Vauxhall tomorrow to do the diagnostics and will take it from there.

    Hopefully I can get this back working soon, parallel parking is quite difficult without the power steering!

  5. #5
    Regular Member Medc's Avatar
    Join Date
    Jan 2010
    Location
    Gloucestershire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I booked the car into Vx for a check, they cleared the fault lights and told me I need a new steering pump.

    I have finally managed to get round to fixing this issue. I bought a second hand steering pump from a breaker via Ebay, I paid £80 inc delivery although most seemed to be about £130+.

    The unit was listed as the steering pump located under the driver's side light behind the bumper which is exactly the one I needed, I think the pump was moved on the facelift models.

    Changing the unit was quite easy, I'll write a how to shortly.

    Once the replacement unit was in place I topped up the steering fluid to the correct level. ( Its the green coloured fluid not cheaper red one, about £10 for 1Lt)

    This resolved the issue straight away and has been perfect for over a week now.

  6. #6
    Forum Moderator soulman's Avatar
    Join Date
    Sep 2006
    Location
    VOTING UKIP IN AVELEY
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    18 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall

    Trim : Astra Twin Top

    Engine : 1.9cdti

    Year : 07

    Default

    nice one !!!!!!!!!!!!!!!!!!!11

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. power steering failure?
    By valvelift in forum Engine & Drivetrain
    Replies: 1
    Last Post: 20th April 2012, 16:38
  2. Power Steering Failure
    By derrybulmers in forum Suspension, Wheels & Brakes
    Replies: 1
    Last Post: 9th August 2011, 20:10
  3. Power steering failure
    By Chris06v6 in forum Engine & Drivetrain
    Replies: 15
    Last Post: 28th July 2011, 06:22
  4. Power steering failure???
    By PeterVV in forum Vectra C / Signum Troubleshooting
    Replies: 2
    Last Post: 7th October 2010, 06:37
  5. Power steering failure
    By Bobfish in forum Vectra C / Signum Troubleshooting
    Replies: 4
    Last Post: 23rd August 2008, 19:59

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •