User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Max 2800rpm in Every Gear

  1. #1
    New Member
    Join Date
    May 2010
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Max 2800rpm in Every Gear

    Hi All, have used this site for solutions for a number of months now, but this time decided to sign up. Great site btw.

    Yesterday, my Signum 2.0 dti Elegance started to lose power and I cant find any answers around the web.

    It doesnt totally lose power, but caps around 2800 rpm (maybe slightly less) in every gear, so still very drivable. If you switch it off, then on again, it is back to perfect working order for a few minutes, then you can feel it cut and cap to around 2800 again. This continues until switched off and on.

    I havent drive it long enough to see if it automatically kicks back in or not. It didnt kick back to normal today driving around 75 miles.

    Anybody come across this problem before? Hoping its not an expensive one.

    Regards,

    Gaz.

  2. #2
    Regular Member Handyandy-UK's Avatar
    Join Date
    Mar 2009
    Location
    Suffolk, Englandshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : BMW 525i

    Trim : SE Touring

    Engine : 3.0

    Year : 2007

    Default

    I know little about the oil burning engines but even given that my first thought is turbo. Maybe a good start would be giving the boost sensor a goo clean out.... maybe give the EGR valve a good de-gunge at the same time.

    I'm sure the oil burning fraternity will be along with better advice very soon though.

  3. #3
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sounds like it's going into limp home mode. Any engine fault lights? Yellow ones?

    Check the boost sensor is clean and the boost hoses for splits. That's where I'd start
    Now I need a turbo to keep up!

  4. #4
    Regular Member solorider's Avatar
    Join Date
    Sep 2006
    Location
    swindon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : Elite

    Engine : 2.0cdti 160bhp

    Year : 2010

    Mileage : 92274

    Default

    on the 2.0 and 2.2dti engines the inlet flaps can get clogged up,this will also affect high speed performance

  5. #5
    Regular Member
    Join Date
    May 2007
    Location
    cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i'd put money on the egr valve.sisters zafira (same engine) had exactly that fault, got a brand new valve for £80 (mate at main dealer) normally about £200 so didn't bother cleaning it and totally cured it.

  6. #6
    New Member
    Join Date
    May 2010
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Not mechanical at all, but will try to sort out / clean what you have all mentioned. Thanks for the feed back and keep your fingers crossed for me.

    As it happens, called the missus and it hasnt happened so far today, which has surprised me. Bound to happen again though, judging on the luck i have had with cars recently.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. cdti stiff gear change, removing gear turret?
    By IrishVectra in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 17th July 2017, 03:14
  2. Reverse gear - weak spring on gear stick
    By Dal5band in forum Bodywork & Interior
    Replies: 5
    Last Post: 20th December 2011, 13:18
  3. Rattling noise over 2800rpm (CDTI 120)
    By rec in forum Engine & Drivetrain
    Replies: 6
    Last Post: 1st November 2010, 15:39
  4. V6 CDTi pulse/surge at 2800rpm
    By Celes in forum Engine & Drivetrain
    Replies: 12
    Last Post: 19th July 2010, 13:38
  5. Stiff gear change, gear selection fine though
    By tramman in forum Engine & Drivetrain
    Replies: 3
    Last Post: 24th November 2009, 23:20

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •