User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: 2.2

  1. #1
    New Member
    Join Date
    May 2010
    Location
    KENT
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 2.2

    Hi all
    newbie to this sight am in need of some advice. Ive got a 2.2 signum 2004 for quite a while now its been playing up!!!!!
    what happens is car drives lovely upto and inc 3000 rpm once over this in a short period of time it will start hesitating then drop into limp mode or just loose power turn off for approx 10 secs start up again and its fine!!! drive it at 65-70 mph will run lovely all day (had to do 160 miles like this and it was OK apart from a large hesitancy as Im accelerating upto 3000rpm (but not every time)
    have had vehicle on two different scanners comes up with fuel pressure sensor and o2 sensor also shows pressure dropping off to default setting but put a live gauge on the pump and even when it starts playing up pressure is still up where it should be. just looses power and pressure waves around a bit but not too drastically (pump was changed about 18 months ago usual shaft snapped)
    I have changed the regulator and 1 of the 02 sensors and the cat last one had fell to bits looking at the exhaust and the 02 sensors it looks like its overfueling both are very black clean up the sensors the y both work again and both switch on and off maf sensor is within spec as well
    anyone got any ideas??????
    cheers
    Dave

  2. #2
    Regular Member simplesi's Avatar
    Join Date
    Aug 2009
    Location
    probably off taking photos
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 1.9 cdti 150

    Trim : elite


    Year : 2006

    Default

    if its a 2.2direct it could be the fuel regulator or the high pressure fuel pump same thing happened to me but got it sorted under warranty.hth p.s. it didnt show any faults on tech2

  3. #3
    Regular Member benny's Avatar
    Join Date
    Feb 2006
    Location
    dudley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    what he said lol... or could bee swirl flaps ....

  4. #4
    New Member
    Join Date
    May 2010
    Location
    KENT
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Swirl flaps?????

  5. #5
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Quote Originally Posted by DAVE.B View Post
    Swirl flaps?????
    Inlet manifold mate, the 2.2 direct has a variable flow manifold.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •