User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 5 123 ... LastLast
Results 1 to 10 of 43

Thread: CDTI 150, more FLAT SPOT HELP please!

  1. #1
    Full Member Vaux-Man-G's Avatar
    Join Date
    Jul 2007
    Location
    Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default CDTI 150, more FLAT SPOT HELP please!

    Folks,

    As you are all well aware of the problems with my dad's CDTI 150....well the flat spot is well and truly back.

    I need your advice as to where I go from here and what I do next.

    So far i've done a fair bit to it:
    • EGR Valve Removed and Cleaned
    • Inlet Manifold Entry Cleaned
    • 3rd Injector Wiring Mod Done
    • Replacement EGR Valve Fitted (was a B-New one)
    • above EGR Valve didnt work so reverted back to original one
    • K&N Panel Filter Fitted
    • Airbox Mod Done
    • Injector Cleaner Sprayed into Inlet Manifold & Throttle Body
    • 10k Boost Spray process done


    My problem is, where do I go from here. I have still got the NEW EGR Valve in the garage as I removed it and have also got a receipt for it (still within 12 months).

    Option's available to me are:
    • Hand the car to Vx and let them pinpoint it
    • Buy ANOTHER new EGR valve and try that
    • Give Vx the car and ask them tro replace the EGR valve for which I have receipt for (but they say they MUST have the car there and "professionally" diagnosed and if it is the EGR, then they will replace it out of the parts 12 month warranty
    • BURN IT!!


    Oh and folks, I havent yet fitted the FIAT gaskets as I believe this is more preventative than a remedy...I will fir them once this is sorted.

    Also, there are no warning lights present....so is going on.

    again chap's and chappesses!



    .


    Bye bye Vec B
    - Hello Siggy!

  2. #2
    Regular Member steve's Avatar
    Join Date
    Nov 2007
    Location
    Ashington, Northumberland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Have you driven another 150 CDTi to compare to yours, your sure its defo not turbo lag. If so then is it before boosting and have ya thought about a remap!

  3. #3
    Full Member Vaux-Man-G's Avatar
    Join Date
    Jul 2007
    Location
    Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Its between 1 - 1.8k rpm. Its like a snail!

    I have driven many other CDTI 150's.....OH and its had a NEW boost sensor too!


    Bye bye Vec B
    - Hello Siggy!

  4. #4
    Regular Member dawasdave's Avatar
    Join Date
    Feb 2010
    Location
    Norfolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Burn it.......

  5. #5
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    When were the filters changed? It's going to be very hard to diagnose with no fault code... Try some millers fuel treatment & the best Italian tune the motor has ever seen.

  6. #6
    Full Member Vaux-Man-G's Avatar
    Join Date
    Jul 2007
    Location
    Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Well it had a service last July..... knows what they actually changed!

    Going to have it serviced earlier this year and will make sure everything is changed!


    Bye bye Vec B
    - Hello Siggy!

  7. #7
    Regular Member
    Join Date
    Aug 2009
    Location
    Camberley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Can you get hold of a power supply, if so power up the egr out of the car with 12 volts and see if the pin pops forward when depressed if so then it's working, my one was solid so had to drill and press out the solanoid assembly and clean, now it is fantastic and moving very well.

  8. #8
    Full Member Vaux-Man-G's Avatar
    Join Date
    Jul 2007
    Location
    Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Sistill View Post
    Can you get hold of a power supply, if so power up the egr out of the car with 12 volts and see if the pin pops forward when depressed if so then it's working, my one was solid so had to drill and press out the solanoid assembly and clean, now it is fantastic and moving very well.
    The pins free mate, I can push it in and out with a very small amount of pressure!


    Bye bye Vec B
    - Hello Siggy!

  9. #9
    Full Member GazVXLINE170's Avatar
    Join Date
    Jun 2007
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : SRI VX-Line Nav

    Engine : 2.0 CDTI [170 PS]

    Year : 2015

    Mileage : 27000

    Default

    Quote Originally Posted by Vaux-Man-G View Post
    The pins free mate, I can push it in and out with a very small amount of pressure!
    Does the valve itself move as freely though? I ask this as the pin operates a rod that sits inside a sleeve in the valve housing, this can fill up with soot and cause the valve to jam shut or open and occasionally stick.

    Gazza4
    Insignia VX-Line Nav CDTI 170.

  10. #10
    Full Member Vaux-Man-G's Avatar
    Join Date
    Jul 2007
    Location
    Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Gazza4 View Post
    Does the valve itself move as freely though? I ask this as the pin operates a rod that sits inside a sleeve in the valve housing, this can fill up with soot and cause the valve to jam shut or open and occasionally stick.

    Gazza4
    Gaz, does that mean a pin moving free in and out does not nesicarily mean the inners are moving free?


    Bye bye Vec B
    - Hello Siggy!

Page 1 of 5 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. CDTI 150 Dreaded flat spot HELP!!!
    By keets in forum Engine & Drivetrain
    Replies: 11
    Last Post: 19th October 2015, 09:26
  2. Flat spot on CDTI 150-how many suffer from this-*POLL*
    By Vaux-Man-G in forum Engine & Drivetrain
    Replies: 121
    Last Post: 22nd January 2013, 07:51
  3. 1.9 cdti 120 poor mpg and flat spot at low revs
    By mattclayt in forum Engine & Drivetrain
    Replies: 6
    Last Post: 17th January 2013, 23:36
  4. CDTi-150 Flat Spot @ 1800rpm
    By Signum7060 in forum Troubleshooting
    Replies: 12
    Last Post: 30th July 2012, 07:27
  5. Could this be the cause of 1.9 cdti 150 flat spot?
    By andreitone in forum Engine & Drivetrain
    Replies: 3
    Last Post: 3rd November 2011, 18:00

Visitors found this page by searching for:

my vectra c cdti had flat spot 1500 revs

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •