User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Code p0380, how do you find faults in glow circuit?

  1. #1
    Regular Member Gazza36's Avatar
    Join Date
    Jan 2010
    Location
    Cornwall
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Code p0380, how do you find faults in glow circuit?

    Hi, got the p0380 code, which relates to the glow plug circuit, it's had new plugs, the old ones were knackered anyway, and a new control unit but the light still comes back? I can't afford to take it anywhere so does anybody know how I go about testing the system to find the fault? The glow plug light comes on like it should, Many thanks Gaz.

  2. #2
    Regular Member
    Join Date
    Apr 2009
    Location
    stockton-on-tees
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Check to see if any of the new 1s have been snapped wen fitted easily dun

  3. #3
    Regular Member Gazza36's Avatar
    Join Date
    Jan 2010
    Location
    Cornwall
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Which bit would be snapped? It's a cdti 150 not a dti if that's what you mean. Ta.

  4. #4
    Regular Member benny's Avatar
    Join Date
    Feb 2006
    Location
    dudley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    the enigne wireing loom has rubbed where it passes near the the top of the bell houseing give the loom a tug and twist and see if it the problems is made better ,,,,

  5. #5
    Regular Member Gazza36's Avatar
    Join Date
    Jan 2010
    Location
    Cornwall
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    blimey. ok I will give it a try.

  6. #6
    Regular Member Gazza36's Avatar
    Join Date
    Jan 2010
    Location
    Cornwall
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Examined the loom around the gearbox and gave it a tug but everything looked fine? Whereabouts will the glow plugs have snapped if thats the case?

  7. #7
    Regular Member Gazza36's Avatar
    Join Date
    Jan 2010
    Location
    Cornwall
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Any help greatly appreciated

  8. #8
    Regular Member benny's Avatar
    Join Date
    Feb 2006
    Location
    dudley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Gazza36 View Post
    Any help greatly appreciated
    give the loom a tug pull it hard away from its mounts and the bell houseing try and twist it slightly .....

  9. #9
    Regular Member BoroDave74's Avatar
    Join Date
    Oct 2008
    Location
    Attleborough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had same error code and had plugs and relay changed. All the suggestions received included the loom one above, checking plugs and finally replacing the temperature sensor behind the front number plate area.
    This last one resolved it for me.

    All the non-Vx mechanics admitted that with the new plugs and relay, the fault as such was not important enough to warrant spending time and money on as the use of the glow plugs isn't as vital as I'd always believed. My car started and ran fine for all the summer, autumn and winter months last year with the spanner light coming on when temperatures were between -5 and 4c; no mpg loss, passed an MOT at a stealer too, emissions fine etc.
    Changed the sensor and spanner light free for the last 5000 miles .

    The part is cheap about £11 or so, I had my mechanic fit it whilst doing something else (brake light relay) so I'm personally not exactly sure where it goes and how easy self-fit might be. hth mate

  10. #10
    Regular Member Gazza36's Avatar
    Join Date
    Jan 2010
    Location
    Cornwall
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    A-ha, it did have a fault code for that as well so that would make sense, Cheers.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. P0380 Glow Plug/Heater Circuit "A" Malfunction
    By sinless in forum Vectra C / Signum Troubleshooting
    Replies: 2
    Last Post: 9th March 2012, 21:38
  2. FAULT CODE HELP: p0380-08 glow device general error
    By merikiito in forum Engine & Drivetrain
    Replies: 4
    Last Post: 19th November 2011, 17:28
  3. P0380 - Glow Device Circuit Low Voltage
    By benwalters82 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 5th March 2011, 01:13
  4. P0380 Stored Glow Plug/Heater Circuit A Malfunction
    By frag45 in forum Engine & Drivetrain
    Replies: 1
    Last Post: 5th January 2011, 13:01

Visitors found this page by searching for:

vectra p0380

OPEL P0380

Vauxhall P0380

vauxhall signum 2006 po380

P0380 OPEL

vauxhall meriva po380

vauxhall opel meriva spanner light p0380

p0380

p0380 vauxhall

Corasa d p0380

p0380 vectra c

p0380 opel corsa c

opel fault code p0380-2

OPEL CORSA P0380-A

vectra sri cdti code p0380p0380-08 vauxhallpreheating light dont wanna go on opel corsa 1.7 dtip0380-08 opelvauxhall meriva 1.7 cdti p0380p0380 meriva 1.7errore p0380 opel corsa c 1.7dtip0380 vauxhall zafiraopel vectra c eroare p0380p0380 zafira b 1.9 cdtiVauxhall DTC P0380-08

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •