User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Sluggish Performance with Signum 1.9 CDTI

  1. #1
    New Member
    Join Date
    Apr 2010
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Sluggish Performance with Signum 1.9 CDTI

    Hi all,

    I've had the car for over a year and so far have had to replace the EGR valve twice and one airflow sensor. It has been back to the dealership over 6 times for poor acceleration and each time, because no faults have registered on the computer, they tell me there is no problem.

    Fault between 1000 and 1500 revs it feels that the accelerator cable is sticking (I know its electronic, but that's what it feels like!) and there's loss of power. The car can also be juddery at times. I have spoken to 1 other owner who has similar problems and not have been able to rectify these problems.

    Can anybody help/advise?

  2. #2
    Regular Member nick_s's Avatar
    Join Date
    Jul 2009
    Location
    Stoke on Trent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Does the car only do short journeys?

    I find when I don't give my z19dth powered vec a decent run, it gets sluggish. Try having a good 30 mile + run on decent fuel and see if there is any difference.

    The juddery feeling could be the swirl pots. It tends to show itself under strain around 1500rpm. That's how mine felt before the inlet manifold/swirl pots and EGR valve were replaced. Got sluggish after a further 4 months of use, but was only doing short journeys. Found after a run down the M1, she was MUCH better.

  3. #3
    Regular Member
    Join Date
    Oct 2009
    Location
    wolverhampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    mate i know how u feel mine as got the same problems vauxhall keep saying nothing up with it whent and collected it today jumped in whent up road still doing the same thing loss of power and often judder so p[hone call back tomorrow see what they r going to do ive had a new egr fitted ecu remapped theres no lights on dash put computer on no errors so god knows whats going to happen know//////1.9cdti 120,,,,,,,,signum 06 plate please help us with our problems,,,,

  4. #4
    New Member
    Join Date
    Apr 2010
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks Guys,
    Was thinking of getting it remapped, but was advised to resolve this problem first. All the dealership would say was that it was probably down to the exhaust system purging it's self. I'll keep watching for any other suggetions. Good Luck with the Dealership baseman.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1.9 CDTi 120 Seems abit sluggish....
    By Vectra Adz in forum Engine & Drivetrain
    Replies: 6
    Last Post: 12th November 2012, 17:14
  2. Sluggish when air con on 1.9 CDTI 150
    By dariousa in forum Engine & Drivetrain
    Replies: 0
    Last Post: 24th July 2012, 22:49
  3. Blue smoke sluggish 3.0 v6 cdti
    By Dam3dx in forum Engine & Drivetrain
    Replies: 13
    Last Post: 24th January 2012, 16:14
  4. 1.9 CDTi (150) sluggish performance
    By nick_s in forum Engine & Drivetrain
    Replies: 17
    Last Post: 7th December 2009, 18:52
  5. CDTi 150 with Sluggish performance and juddering tickover
    By markluk in forum Engine & Drivetrain
    Replies: 4
    Last Post: 15th July 2009, 20:24

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •