User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Camshaft control sensor switch??? help me!!

  1. #1
    New Member
    Join Date
    Apr 2010
    Location
    County Durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Camshaft control sensor switch??? help me!!

    my car has been in a garage for 2 weeks and they don't know what's wrong with it! they have already fitted a 'camshaft control sensor switch' and that cleared the diagnostics but it has made no difference to the car. the car won't rev up and the turbo dosen't kick in at all and it runs like crap, it shakes the whole car and sounds like a tractor? it's a 2004 sri 150 cdti, i've been without my car for 4 weeks!! and im beggining to lose hope

    any suggestions?

  2. #2
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra-c

    Trim : sri

    Engine : cdti

    Year : 2004

    Mileage : 98,000

    Default

    i would bet its the EGR as these are a common cause with running problems!, on the 120 + 150 cdti. does it tickover ok ? but wont realy go any!, do you have a exhaust fumes smell coming in through the heater vents when driving slow or standing, the inlet manifold could well be faulty!, another common fault!, the boost sensor and throttle body are a good idea to clean with mid - high mileage cdti's.
    Last edited by the-wizard; 28th April 2010 at 15:23.

  3. #3
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra-c

    Trim : sri

    Engine : cdti

    Year : 2004

    Mileage : 98,000

    Default

    tell them to clean these parts and go from there!. (yellow circle boost sensor// pink circle throttle body// red square EGR(START WITH EGR FIRST!). there's a good guide on how to clean the EGR correctly in the 'how to' section on this forum.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. HELP - where is camshaft sensor.....
    By sri150 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 30th December 2013, 18:24
  2. Camshaft sensor Q?
    By Barlow in forum Engine & Drivetrain
    Replies: 4
    Last Post: 11th April 2012, 23:03
  3. Vectra C 2.2 Camshaft sensor
    By robert31 in forum Vectra C / Signum Troubleshooting
    Replies: 9
    Last Post: 8th May 2011, 23:33
  4. camshaft sensor
    By lusk in forum Engine & Drivetrain
    Replies: 4
    Last Post: 6th March 2011, 19:30
  5. camshaft sensor???
    By evyboy in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 21st January 2010, 17:18

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •