User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: Problem vith Vectra 2.2sri

  1. #1
    New Member
    Join Date
    Apr 2010
    Location
    Aberdeen
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Problem vith Vectra 2.2sri

    Hi all
    Just like to say hi and get some advice on my Vectra 2.2 Direct SRI. The engine management light has came on and it has developed a miss fire, When in neutral it rev's up fine but when you try and drive it it won't go over 2000 rev's and has no power I have changed the plugs today but not any better. Its an 05 and only done 41000 miles

  2. #2
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default

    Sounds like the HP pump or reg mate. Not cheap.

  3. #3
    New Member
    Join Date
    Apr 2010
    Location
    Aberdeen
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Is this a main dealer job or can any garage do this. What sort of price do you think

  4. #4
    New Member
    Join Date
    Apr 2010
    Location
    hertfordshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    sounds like a cam or crank sensor like its in limp home if the engine mangenment light is on its a plug in im afraid

  5. #5
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default

    If its the pump you can buy and fit it yourself, its the one on the fuel rail mate. Your best getting the code's read however, you never know it could be the coil pack but odds on its the pump. There was a BBC watchdog feature on it a while back.

  6. #6
    New Member
    Join Date
    Apr 2010
    Location
    hertfordshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    forgot to mention another option is the waste spark unit may be breaking down a more likely option if it idles ok but not under load hope some help

  7. #7
    New Member
    Join Date
    Apr 2010
    Location
    Aberdeen
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thanks think ill put it in to the garage let then deal with it ill let you guys the out come.

  8. #8
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by bear1966 View Post
    forgot to mention another option is the waste spark unit may be breaking down a more likely option if it idles ok but not under load hope some help
    Yep ,the coil pack as said, the symptoms of a duff HP pump are fine at idle and revving, but as soon as its under load and above 3500 rpm it goes caput, just as he described. This is a very very common fault.

  9. #9
    Regular Member
    Join Date
    Apr 2010
    Location
    My House
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Need to be careful as the Hp pump can give a severe lack of power even at a standstill whilst revving..changed 2 this week and both had severe power loss whilst revving at standstill

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. vectra 2.2sri . What exhaust fits
    By R-o-b in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 30th March 2011, 21:30
  2. Vectra 2.2SRI Direct Misfire/Limp Mode
    By craig123 in forum Troubleshooting
    Replies: 3
    Last Post: 28th June 2009, 22:28
  3. Problem...? Vectra SXI...problem with starting after filling with fuel?
    By doozer in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 8th November 2008, 09:40
  4. Cyb 2.2Sri
    By cyb in forum Quick Photo Album
    Replies: 18
    Last Post: 1st July 2005, 09:40

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •