User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: lumpy on switch off

  1. #1
    Regular Member
    Join Date
    Jan 2009
    Location
    liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Question lumpy on switch off

    over the last couple of days when i switch the ignition off the engine seems to rock or vibrate, for want of another word.as if its trying to run on and rocking? its never done this before and i cant think why it would.i did think engine mounting but as im not really technically gifted thats a guess.any suggestions folks ?? by the way its an 05 19cdti zdth [150]

  2. #2
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi

    Trim : XP NAV

    Engine : 1.9 CDTi 150

    Year : 2007

    Default

    What engine? EGR issues can cause this.

  3. #3
    Regular Member KevinG's Avatar
    Join Date
    Nov 2008
    Location
    South Bucks
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    didnt they used to call this pinking, used to be down to timing issues i think before the days of EGR and such stuff, showing my age
    Last edited by KevinG; 21st April 2010 at 23:13.

  4. #4
    Regular Member
    Join Date
    Jan 2009
    Location
    liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yeh thats what i thought.on a petrol engine i'd say the timing was out but i have'nt got a clue about diesel engines ?

  5. #5
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi

    Trim : XP NAV

    Engine : 1.9 CDTi 150

    Year : 2007

    Default

    It will be a slightly sticking EGR mate.

  6. #6
    Regular Member
    Join Date
    Jan 2009
    Location
    liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    cheers dan,i'll take it out and give it a good scrub.had it 16months now and haven't taken it out.dont know if its ever been taken out .its done 55k now so must be due a scrub.and i'll do that boost sensor as well.will i need new gaskets? and whats all this blanking off business ?

  7. #7
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra-c

    Trim : sri

    Engine : cdti

    Year : 2004

    Mileage : 98,000

    Default

    If that don't solve it , with it being a diesel it can only be 1 thing!!, the diesel supply isn't being cut off immediately upon switch off.

  8. #8
    Regular Member Chocki's Avatar
    Join Date
    Jul 2006
    Location
    Wolverhampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    On the 1.9s there is an electric throtle which shuts the air off to the engine when you turn it off, if this is sticking or the EGR is sticking open, air can get past into the inlet manifold and cause exactly what you describe.

  9. #9
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra-c

    Trim : sri

    Engine : cdti

    Year : 2004

    Mileage : 98,000

    Default

    [quote=the-wizard;1239635]If that don't solve it , try removing the 'throttle body' that has a butterfly flap in it and it may not be openening + closing fully', ''forgot this earlier''. give it a good clean + work it by hand (its spring loaded and firm to move by hand).

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Small 12v Auto circuit for on/off switch for PDC switch
    By markm in forum Electrical & ICE (including SatNav)
    Replies: 8
    Last Post: 8th October 2012, 23:00
  2. lumpy idling
    By beat275 in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 11th September 2011, 15:56
  3. headlight switch window switch in blue
    By delboy2028 in forum Parts for sale
    Replies: 1
    Last Post: 26th May 2010, 08:56
  4. Bit lumpy?
    By speedo in forum Engine & Drivetrain
    Replies: 2
    Last Post: 25th November 2007, 19:09

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •