User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: 2.2 direct failed mot on emissions,

  1. #1
    Regular Member
    Join Date
    Mar 2009
    Location
    loughborough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 2.2 direct failed mot on emissions,

    Hi, I have recently bought a 04 reg 2.2 direct vectra sri.

    I took it for MOT today and it failed on the emissions. It seems that the CO %vol is way to high

    (Max limit is 0.300)

    Mine is 6.036

    Also the emission light has come on. although i have noticed this on before then it went off.

    Has anyone eles had this problem or does anyone know what it could be

    Thanks

  2. #2
    Regular Member GAZWAH's Avatar
    Join Date
    Feb 2009
    Location
    darlington uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    sounds like your catt is goosed,or lamba knackered....get them to plug it in and read it

  3. #3
    Regular Member
    Join Date
    Mar 2009
    Location
    loughborough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ok, was kinda hopeing it would be something cheap and easy to sort.

  4. #4
    Regular Member kenp's Avatar
    Join Date
    Feb 2008
    Location
    Kr. Hyllinge, Denmark
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C


    Engine : 2.2 Direct

    Year : 2004

    Default

    Mine failed to.. but only at 0.428.. but was your engine warm? and had a good spin to clean it up.. probaly wont help to get it all the way down.

    Also besides the suggestions above, check for holes in the exchaust.

  5. #5
    Regular Member benny's Avatar
    Join Date
    Feb 2006
    Location
    dudley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    seems there failing alot on the inlet manifold flaps problem ..get it tech tested and see what the codes are ......

  6. #6
    Regular Member
    Join Date
    Mar 2009
    Location
    loughborough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Unhappy

    Quote Originally Posted by benny View Post
    seems there failing alot on the inlet manifold flaps problem ..get it tech tested and see what the codes are ......
    Would this be swirl flaps? as this is what it comes up with on a fault reader.

    It says swirl flap sticking , it has a fault code but i have forgoten it.

  7. #7
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Quote Originally Posted by clive3373 View Post
    Would this be swirl flaps? as this is what it comes up with on a fault reader.
    Yes mate

  8. #8
    Regular Member Sambor's Avatar
    Join Date
    Apr 2010
    Location
    Elgin
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by clive3373 View Post
    Would this be swirl flaps? as this is what it comes up with on a fault reader.

    It says swirl flap sticking , it has a fault code but i have forgoten it.
    It comes on my VC the same fault.Two weeks ago i clean swirl flaps and now working better.But i'll see in May on MOT?

  9. #9
    Regular Member benny's Avatar
    Join Date
    Feb 2006
    Location
    dudley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by clive3373 View Post
    Would this be swirl flaps? as this is what it comes up with on a fault reader.

    It says swirl flap sticking , it has a fault code but i have forgoten it.
    yep ....will need the new repair kit ......

  10. #10
    Regular Member
    Join Date
    Mar 2009
    Location
    loughborough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Would stuck swirl flaps make the co% high. Or could this be an unrelated fault?

    Thanks for your replys

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Failed MOT due to emissions
    By johnnylegs in forum Vectra C / Signum Troubleshooting
    Replies: 0
    Last Post: 20th June 2011, 20:50
  2. Failed mot on emissions
    By G4GAV in forum The 'Off Topic' room
    Replies: 8
    Last Post: 9th March 2011, 21:21
  3. emissions values for 2.2 Direct
    By DaveG in forum Engine & Drivetrain
    Replies: 5
    Last Post: 3rd April 2010, 15:07
  4. emissions failed
    By rick1965 in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 18th September 2009, 23:11
  5. Failed MOT on emissions
    By simac in forum Vectra C / Signum Car Chat
    Replies: 30
    Last Post: 18th June 2008, 19:44

Visitors found this page by searching for:

co emissions too high vectra c 2.2

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •