User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: error code P0234 - Boost pressure control

  1. #1
    New Member
    Join Date
    Jan 2010
    Location
    Cirencester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default error code P0234 - Boost pressure control

    Hi

    I've had this error code a couple of times ( engine spanner light on and car goes into limp mode), after hard accelerating. Clears next time car is started.

    2.0 DTi 2002 with Y20DTH engine.

    car drives OK otherwise.

    Engine diagnostics place says is a boost pressure control error.

    Any suggestions as to the most likely cause?

    thanks

  2. #2
    Admin & Merchandise Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    72 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : insignia

    Trim : irmscher

    Engine : 2.0 cdti

    Year : 2009

    Default

    Without searching i would assume its the boost valve maybe its clogged up and dirty,quick clean with carb cleaner might help
    Plus check all boost pipes for air leaks and splits

    Irmscher Insignia CDTI 130

    MOD'S...Irmscher front spoiler, Irmscher mats, Irmscher door pins, Irmscher rear spoiler, Irmscher grille, Irmscher skirt & exhausts,Irmscher Roof spoiler MOD'S TO COME..Side skirts,Wheels

  3. #3
    New Member
    Join Date
    Oct 2009
    Location
    Cleveland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default P0234 Overboost Condition

    I have had P0234 overboost code quite a few times now. I currently drive a Vectra C 2.2Dti 2003, and it only ever occurs whilst towing caravan. I have been frustrated with it for nearly 3 years now. I have had ECU updated by Vauxhall (still happening after update ), had it to numerous garages and nobody has ever been able to pinpoint what was causing it. A few weeks ago i took Boost pressure sensor out (module on inlet manifold with Bosch on it). It was quite black so i cleaned it with some white spirit and a soft paint brush until the needle in the centre became a brassy colour again( just be careful doing this as i understand module is quite delicate ) and put it all back together. I have just been away for the weekend with caravan and have suffered no problems whatsoever. Fingers crossed this has cured my problem. If i have any more problems i will post on here. Hope this will be of some help to people suffering P0234 condition.

  4. #4
    Regular Member barney490's Avatar
    Join Date
    Dec 2009
    Location
    PRESTON
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    nige? what code reader do you use, i am looking at this on ebay,

    http://cgi.ebay.co.uk/USB-OBD2-Diagn...item35a9cbff21

    cheers

  5. #5
    New Member
    Join Date
    Oct 2009
    Location
    Cleveland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi Barney490. I am not sure which code reader it was that was used because i took it to a local garage and he plugged his machine in to find the fault code and reset the fault. I don't think all diagnostic machines will actually read Vectra codes because i tried one at another garage, and theirs wouldn't work. Like i said in my previous post, my car has brought spanner light on every time i have had caravan on for last 2-3 years but this weekend it never did it, hopefully from just cleaning boost sensor. Sorry i cant give you the name of diagnostic machine, but i know from the one he was using, it wasn't just the ones you can buy for 50 quid or so.

  6. #6
    New Member
    Join Date
    Oct 2009
    Location
    Cleveland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I previously posted that i had removed and cleaned the boost pressure sensor, but it did not cure the problem. I have since spoken to a mechanic from Vauxhall and told me what to do to cure the P0234 overboost problem. Carefully remove circlip on wastegate rod on side of turbo, then again carefully remove actuator rod from turbo. It is a bit tight but you need to somehow hold rod with pliers so it doesn't move around too much, then loosen nut (10mm i think! ) underneath the top section of rod. Once loose, you need to just turn the top section (that you took off side of turbo) anti-clockwise by just HALF A TURN, so in effect lengthening the rod. Re-tighten nut underneath and re-connect to turbo, making sure it is lined up nice and straight so moves freely once connected. (Just put a drop of oil on little arm before re-connecting). Put ciclip back on, being careful as they can just fly off!! Doing this to mine has solved the problem, as just done 800 miles with caravan on, and had no problem whatsoever. Doing this to your car will make it boost slightly less, but you won,t notice any difference. Good luck.

  7. #7
    Ex-Staff Full Member John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    Quote Originally Posted by Nige873 View Post
    I have had P0234 overboost code quite a few times now. I currently drive a Vectra C 2.2Dti 2003, and it only ever occurs whilst towing caravan. I have been frustrated with it for nearly 3 years now. I have had ECU updated by Vauxhall (still happening after update ), had it to numerous garages and nobody has ever been able to pinpoint what was causing it. A few weeks ago i took Boost pressure sensor out (module on inlet manifold with Bosch on it). It was quite black so i cleaned it with some white spirit and a soft paint brush until the needle in the centre became a brassy colour again( just be careful doing this as i understand module is quite delicate ) and put it all back together. I have just been away for the weekend with caravan and have suffered no problems whatsoever. Fingers crossed this has cured my problem. If i have any more problems i will post on here. Hope this will be of some help to people suffering P0234 condition.
    You know what that is great to hear, I had the same problems with this last year and cleaned the boost sensor after the carvan season had finished but i've not been away with it yet so fingers crossed

    Quote Originally Posted by Nige873 View Post
    Hi Barney490. I am not sure which code reader it was that was used because i took it to a local garage and he plugged his machine in to find the fault code and reset the fault. I don't think all diagnostic machines will actually read Vectra codes because i tried one at another garage, and theirs wouldn't work. Like i said in my previous post, my car has brought spanner light on every time i have had caravan on for last 2-3 years but this weekend it never did it, hopefully from just cleaning boost sensor. Sorry i cant give you the name of diagnostic machine, but i know from the one he was using, it wasn't just the ones you can buy for 50 quid or so.
    Cheaper code readers don't work on the DTi

  8. #8
    New Member
    Join Date
    Oct 2009
    Location
    Cleveland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I am 99% sure that what i have just done has cured problem. I drove approx 200 miles with no problems, then pulled into services and set wastegate rod back to original setting and within the next 50-60 miles the car went into limp 3 times. So then i just wound it back that half a turn again, and had no problems ever since. Good luck

  9. #9
    Regular Member campbell's Avatar
    Join Date
    Jul 2009
    Location
    manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    could sombody please do a how to on this lenghening arm because its a fault in all vectras and vauxhall dont addmit it haha thanks kiel

  10. #10
    New Member
    Join Date
    Sep 2010
    Location
    Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Why is there no HOW2 guide on this yet??!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fault Code P0234 - Boost Pressue
    By Gazz in forum Engine & Drivetrain
    Replies: 0
    Last Post: 15th October 2012, 10:48
  2. P0234 Error Code Definition
    By viper8 in forum Engine & Drivetrain
    Replies: 16
    Last Post: 31st December 2011, 14:10
  3. P0234 Error code.
    By ectraz in forum Electrical & ICE (including SatNav)
    Replies: 17
    Last Post: 23rd September 2011, 20:23
  4. Replies: 7
    Last Post: 22nd August 2011, 14:41
  5. Replies: 6
    Last Post: 3rd September 2009, 16:40

Visitors found this page by searching for:

how change p0234 opel vectra dti c 2003

opel insignia 1.6turbo p0234

p0234 boost pressure control circuit negative deviation

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •