User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: Centre Display Not Switching Off With Ignition

  1. #1
    Regular Member DanR's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Centre Display Not Switching Off With Ignition

    Hi Guys,

    Just picked my car up from the garage and have noticed that the centre display stays switched on permanently (keys been out for about 30 minutes now and it's still on), radio & satnav screens disappear but I can still access the phone and BC screens.

    Before I phone the garage and moan at them is this normal beahviour or is there a setting somewhere that controls this?

    Cheers

    Dan

  2. #2
    Full Member Knight Rider's Avatar
    Join Date
    Apr 2008
    Location
    Motherwell
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by DanR View Post
    Hi Guys,

    Just picked my car up from the garage and have noticed that the centre display stays switched on permanently (keys been out for about 30 minutes now and it's still on), radio & satnav screens disappear but I can still access the phone and BC screens.

    Before I phone the garage and moan at them is this normal beahviour or is there a setting somewhere that controls this?

    Cheers

    Dan
    Have you tried disconnecting the battery for about 10mins sometimes this helps to reset things. hth


  3. #3
    Regular Member DanR's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Cheers, that sorted it!

  4. #4
    Full Member Knight Rider's Avatar
    Join Date
    Apr 2008
    Location
    Motherwell
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by DanR View Post
    Cheers, that sorted it!
    No probs mate,glad to help.


  5. #5
    Regular Member DanR's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Centre Display Not Switching Off With Ignition - Update

    Hi Guys,

    Just thought I'd post an update on this;

    Two days after disconnecting the battery this issue returned, disconnecting the battery again had no effect. I figured as the display couldn't draw that much current it would be okay to leave over the weekend - how wrong I was!

    Battery managed to drain down to 4 volts and I had to get the recovery guys out for a jump start . Whipping the negative lead off until I used the car the following day solved that problem!

    However the issue appears to be related to the bluetooth problems that I have been having (module doesn't attempt to search for nearby devices) and the bluetooth unit has failed, holding the display on.

    According to the Dealer's Vauxhall tech new units are rare as rocking horse poo, however a quick call to my local Vauxhall dealer and I can have one in 48 hours so I am awaiting a new bluetooth module to be fitted, fingers crossed!


    Dan

  6. #6
    Admin plasma's Avatar
    Join Date
    Mar 2006
    Location
    On the Forum
    Post Thanks / Like
    Mentioned
    136 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    136 Post(s)
    Tagged
    0 Thread(s)

    Default

    Screwed bluetooth module is causing it.... Unplug the bluetooth module and the rest of it will be ok.. Only answer is a new module I'm afraid.... (Once you've confirmed it is that).

    Seen in happen in another members car recently, new module cured it.
    Plasma's Tech2 services are now partially open and able to provide services



    Come Join our new forum Insignia Owners.com for all your Insignia chat and needs

  7. #7
    Regular Member DanR's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thanks Plasma,

    The module is indeed faulty and the dealer SHOULD have put one on order yesterday - after getting a price from Vauxhall I'm glad I'm not footing the bill though!

    Cheers


    Dan

  8. #8
    Regular Member Robsey's Avatar
    Join Date
    Dec 2006
    Location
    North East Cheshire
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default

    Yes, I have a basic Nokia CK7-W fitted to my CD70, and when there is a bluetooth connection....and a call in progress, or I am playing my mp3's through the phone, then it holds the display active.

    Once the call is ended, or the bluetooth is no longer active then the screen shut's off.

    Obviously the faulty unit in your case was convinced you were still in mid call and hence holding the display on.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Centre display
    By Hyperhart in forum Electrical & ICE (including SatNav)
    Replies: 15
    Last Post: 29th April 2012, 07:55
  2. advise on centre display
    By dcm23251981 in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 29th January 2012, 09:22
  3. Help with centre display smd's
    By bopster in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 20th November 2011, 22:24
  4. Radio comes on automatically when switching on ignition....
    By waterbourne in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 7th January 2010, 22:19
  5. centre display
    By vectra in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 2nd July 2007, 17:42

Visitors found this page by searching for:

my display has gone off when engine off in my vectra c

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •