User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: Dodgy heater!

  1. #1
    Regular Member keith1983's Avatar
    Join Date
    Dec 2008
    Location
    Sheffield / Spalding
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra 1.8 SRi

    Trim : SRi

    Engine : Z18XE

    Year : 2004

    Default Dodgy heater!

    My heater has started playing up and the blower only works on setting number four. Has anyone else had this problem? If so what was the solution?

  2. #2
    Regular Member
    Join Date
    Feb 2010
    Location
    Newcastle upon Tyne
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Have you had water in the passenger footwell?

  3. #3
    Regular Member keith1983's Avatar
    Join Date
    Dec 2008
    Location
    Sheffield / Spalding
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra 1.8 SRi

    Trim : SRi

    Engine : Z18XE

    Year : 2004

    Default

    not that I've noticed? If I have what would that indicate?

  4. #4
    Regular Member benwalters82's Avatar
    Join Date
    Nov 2009
    Location
    Redruth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SXI

    Engine : 2.0DTI

    Year : 2002


  5. #5
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by benwalters82 View Post
    How did you find that???
    Now I need a turbo to keep up!

  6. #6
    Regular Member
    Join Date
    Feb 2010
    Location
    Newcastle upon Tyne
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    check that post out, very common problem so i would start by checking your drains asap. I had my heaters go off the other month it was caused by water damage from a blocked drain (the drain was cleared over 6 months before and it took that long for fault to develop! On mine its slightly different as i have duel climate control but i managed to fix it with a can of WD40! Basically the connections on the resistor were totally eroded. To fix i carefully cleaned up the points as best i could by scraping as much c**p as i could then sprayed it with WD40 (this is good cos does not conduct electric but prevents rust/erosion)put it back together and it worked a treat. i did the same with every connector i could get to from behind the glovebox to try and avoid any future problems! Also a tip my heaters have never worked as well since i put a bit 3in1 in on the top of the motor (behind pollen filter get to from engine bay) they did have a slight squeek but better then new now! Hope this helps and you dont have to spend you hard earned £££ because of poor VX design!

  7. #7
    Regular Member keith1983's Avatar
    Join Date
    Dec 2008
    Location
    Sheffield / Spalding
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra 1.8 SRi

    Trim : SRi

    Engine : Z18XE

    Year : 2004

    Default

    Thanks for the info guys. Certainly gonna give the resistor pack, drain clearing a go and see how I get on. I just hope the motor is ok. It does work well on setting 4 so fingers crossed!

  8. #8
    Regular Member benwalters82's Avatar
    Join Date
    Nov 2009
    Location
    Redruth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SXI

    Engine : 2.0DTI

    Year : 2002

    Default

    remember to try the 79p maplins fix before forkin out on a new resistor pack.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Dodgy DAB....
    By JagRigger in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 9th April 2011, 08:01
  2. hid kit dodgy?
    By duncan2008 in forum Electrical & ICE (including SatNav)
    Replies: 36
    Last Post: 12th May 2009, 17:32
  3. dodgy egr i think!
    By littlesxi in forum Diesel Engine related
    Replies: 12
    Last Post: 21st March 2008, 23:59
  4. Dodgy Ref
    By AJA in forum Comedy & Humour
    Replies: 1
    Last Post: 11th February 2007, 04:51

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •