User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: Misfire, injector mod already done.

  1. #1
    Regular Member Gazza36's Avatar
    Join Date
    Jan 2010
    Location
    Cornwall
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Misfire, injector mod already done.

    Hi, car is a cdti 150 05 plate, been having an awful misfire and today the garage said it's because the connector on the no3 injector is wrong, however i think this is only because it's had the mod and when i mentioned it they had never heard of the mod. Is there any way of testing the connector to the injector and what else could be causing the misfire? Any help greatly appreciated, really desperate now

  2. #2
    Regular Member winnie2457's Avatar
    Join Date
    Dec 2009
    Location
    kings lynn, norfolk
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    If your misfire is below 2200revs or on partthrottle it could be the egr valve or swirl valves on inletmanifold check these and follow how2 on here to clean the egr mate hope this helps

  3. #3
    Regular Member Gazza36's Avatar
    Join Date
    Jan 2010
    Location
    Cornwall
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Sorry forgot to say that manifold has been done, also cleaned and lubricated egr valve as per how2.

  4. #4
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Defo an EGR issue, probably sticking.

  5. #5
    Regular Member Gazza36's Avatar
    Join Date
    Jan 2010
    Location
    Cornwall
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Ok, i will do it again.

  6. #6
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Gazza36 View Post
    Ok, i will do it again.
    Make sure you don't oil/grease the spring/shaft too much as this can cause sticking.

  7. #7
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Deffo agree i tell everyone this! not grease, i use a elec contact spray after cleaning, grease can cause sticking. as ive stated many times when he EGR is parted work the spring by hand, look for the shaft part thats ONLY exposed when working the spring!!, this shaft part runs through a shroud! and i find this part NEEDS getting at and cleaning and spraying with carb cleaner, DONT lubricate after with grease cos this will attract muck after, im in the process of trying different lubricants to see which is best!, ( IM AFTER AN OLD EGR TO EXPERIMENT WITH ??)
    Last edited by the-wizard; 13th April 2010 at 16:00.

  8. #8
    Regular Member Gazza36's Avatar
    Join Date
    Jan 2010
    Location
    Cornwall
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I put a load of 3 in 1 on it, is that alright? It's still doing it, it sounds like the waste gate goes mental when it happens??

  9. #9
    Regular Member Gazza36's Avatar
    Join Date
    Jan 2010
    Location
    Cornwall
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I'm going to strip it one more time and remove some of the oil and see if it makes any difference, if I buy a new egr and it doesn't work is there anything else it could be? Cheers

  10. #10
    Regular Member Gazza36's Avatar
    Join Date
    Jan 2010
    Location
    Cornwall
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Now fixed, new egr sorted it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help please....stuttering, ?misfire...3rd injector or EGR??
    By marky2027 in forum Engine & Drivetrain
    Replies: 12
    Last Post: 28th June 2012, 21:59
  2. misfire and lumpy idle since new injector
    By aidy-cdti in forum Engine & Drivetrain
    Replies: 3
    Last Post: 11th August 2011, 23:03
  3. Injector Wiring Loom (common fault on 3rd injector)
    By Vaux-Man-G in forum Parts for sale
    Replies: 3
    Last Post: 8th October 2010, 12:18
  4. Does the No 3 injector wiring really solve the misfire?
    By bygumlad in forum Engine & Drivetrain
    Replies: 0
    Last Post: 13th April 2009, 16:40

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •