User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Engine oil light

  1. #1
    Regular Member vectrasri-j's Avatar
    Join Date
    Sep 2009
    Location
    luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTI 120

    Year : 2006

    Mileage : 100000

    Default Engine oil light

    hi my car seems to be using up alot of engine oil i topped it up about 3-4 weeks ago when the light came on and last night after a bit of heavy driving engine oil light came back on and i topped it up again. is there a underlying problem or is this normal it also looses coolant water and needs regulat top ups. kind of getting me worried at the moment. its a 3.2 v6
    Thankss

  2. #2
    Regular Member
    Join Date
    Aug 2006
    Location
    Bedfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I would say you have a problem my old gsi never needed topping up oil or water between services. Can you see any leaks or stains on the driveway ?

  3. #3
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If mines driven carefully it uses very little/no oil. Give it a good kicking and it starts to use a bit of oil. I think the high revs just push a bit of oil pass the rings. Also, all engines are different. Some use oil, some don't. I think VX starte that its ok to use 1000ml per 1000 miles. Over that is a problem.

    Coolant water? Check everywhere for leaks.
    Now I need a turbo to keep up!

  4. #4
    Ex Vec-C Admin ed taylor's Avatar
    Join Date
    Oct 2005
    Location
    Looking Through a Camera Lens.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : Elite

    Engine : 3.2 V6

    Year : 04

    Mileage : 000

    Default

    My 3.2 uses little to No oil even when my right foot is a bit heavy. I used to have a Sierra that driven normaly it used No opil. But if I belted it. It used more oil. So you mighjt not have a problem. But worth any investigation, just incase.

  5. #5
    Regular Member vectrasri-j's Avatar
    Join Date
    Sep 2009
    Location
    luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTI 120

    Year : 2006

    Mileage : 100000

    Default

    thanks for your replies guys, i cant see any leaks or visible oil stains on my driveaway thats what got me confused, where is the oil going? and coolant loss has been there since ive brought the car, going to get it checked up this weekend and again cant spot any leaks from pipes coolant tank etc.

  6. #6
    Regular Member jlock's Avatar
    Join Date
    Jun 2009
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : BMW 525i

    Trim : M-Sport

    Engine : 2.5l Straight 6


    Default

    I know mines a 2.2 but my oil light has been on for a wee while now but everytime i check it its full :s

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Replies: 17
    Last Post: 16th August 2012, 10:07
  3. Engine and Spanner Light Before I Start The Engine
    By corderz in forum Engine & Drivetrain
    Replies: 14
    Last Post: 24th March 2011, 18:48
  4. No throttle, traction control light, engine management light
    By si260188 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 9th May 2010, 21:45
  5. Replies: 3
    Last Post: 28th April 2009, 19:49

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •