User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: 2.2 Dti temperature gauge problem

  1. #1
    Regular Member
    Join Date
    Feb 2010
    Location
    Newcastle upon Tyne
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Post 2.2 Dti temperature gauge problem HELP PLEASE!

    Hi,

    I have a 2003 Vectra 2.2 Dti Elite have owned it for a couple of years now most of the common problems sorted thanks to this site!(Thanks all!) I have searched and searched for a fix for this problem but i cant find a solution.

    My Vectra temperature gauge stopped working about 6 months ago, it does move up to just under 80 when in traffic after at least 2 hours of running engine (taxi driver) however as soon as i build up any speed it drops to the bottom again.

    I have not noticed any difference in performance or MPG.

    Car has full service history and i have just had full service 2 months ago (after gauge started playing up the garage had a quick look but did not know what was causing the problem) So it has been well looked after 120000 miles on clock, otherwise running well!

    Also the garage said that I have a warning light if it overheats and the gauge does not display is this correct or am I taking a chance driving it?

    thanks in advance for any help or if anyone can point me in the right directionHE
    Last edited by j88nya; 6th April 2010 at 20:00.

  2. #2
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Get the thermostat changed mate

  3. #3
    Regular Member
    Join Date
    Feb 2009
    Location
    Stockton on Tees
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I warning light does come on in the dash if the temp gets too hot. Not sure if its linked to gauge though as mine was working when it threw its belt off and over heated.

  4. #4
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by dh.dti View Post
    Get the thermostat changed mate
    Now I need a turbo to keep up!

  5. #5
    Regular Member
    Join Date
    Feb 2010
    Location
    Newcastle upon Tyne
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    is this the kid? http://cgi.ebay.co.uk/OPEL-VECTRA-C-...item45f1215f09

    Seems really cheap also i am no mechanic but know my way around a spanner would you recomend changing myself or is it a garage job?

    thanks again

  6. #6
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Had mine changed a couple of years ago on my old dti, part was complete with the housing from the dealer @ about £40, my mate fit it whike he was servicing it

  7. #7
    VIP-Member puppet's Avatar
    Join Date
    Feb 2010
    Location
    East Ayrshire
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia 1.8 SRi

    Trim : VX Line Red

    Engine : 1.8VVT

    Year : 2011

    Default

    I know yours is a diesel, whereas mine is a petrol, but this sounds like exactly the same issue I had with mine a few months back. Took forever to get up to temp, and as soon as I was out on the open road the temp dropped like a stone. New thermostat (+housing) was the cure for me. Was only about £30 or so. Heats up perfectly now and nice steady temp throughout.

    Not a difficult item to change if yours is similar to mine. Couple of coolant hoses to remove, temp probe multiplug, and 2 or three torx bolts. Hardest bit is trying to get the new gasket to stay in place in it's recess while you offer the new housing up to the side of the engine block. I ended up using a few miniscule drops of glue just to hold it in place.


  8. #8
    Regular Member
    Join Date
    Feb 2010
    Location
    Aldermaston (Berks)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi there, i have the sri dti 2.2, i had the exact same problem as you where the temp gauge did not seem to work properly, bearing in mind diesels take longer to warm up than petrol.
    I cured mine by fitting a new thermostat and housing, was a very easy job to do aswell, it now warms up within 5 to 7 miles of driving and sits just below 90 degrees on the gauge.
    Seems to be one of the many common problems on the 2.2 lol.

  9. #9
    Regular Member
    Join Date
    Feb 2010
    Location
    Newcastle upon Tyne
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Cheers, cant find a 'how to' to change it any tips?

  10. #10
    Regular Member Aikon58's Avatar
    Join Date
    Feb 2010
    Location
    Englandshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : shatch- sports hatch

    Trim : cheap plastics

    Engine : metal

    Year : 1901

    Mileage : 999

    Default

    Take off your ecotec cover from the engine,and then get a pair of long handled grips and remove the top hose from the thermostat housing,and then just undo the bolts of the housing,and put the new housing on,replace the top hose,run the engine up to warm with the cap of the header tank,and top up with anti freeze,until the coolant is on the level,replace the cap,and check the coolant when cold and top up if needed.
    Thats just the basics.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Temperature gauge
    By any-mgzt in forum Engine & Drivetrain
    Replies: 14
    Last Post: 8th December 2012, 23:33
  2. temperature gauge
    By rfc52 in forum Vectra C / Signum Car Chat
    Replies: 10
    Last Post: 24th November 2012, 15:20
  3. Temperature gauge
    By ziggy1 in forum Vectra C / Signum Troubleshooting
    Replies: 5
    Last Post: 22nd November 2012, 02:35
  4. Temperature gauge problem
    By Martinlw in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 14th March 2012, 12:05
  5. Temperature Gauge problem
    By Trembem in forum Engine & Drivetrain
    Replies: 15
    Last Post: 22nd February 2011, 20:08

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •