User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Vectra Stering Problem

  1. #1
    Regular Member bighammerfan's Avatar
    Join Date
    Sep 2008
    Location
    hillingdon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Vectra Stering Problem

    Hi. I have a 2001 2.2 LS Vectra and recently when i start up from cold i find the power steering sometimes does not work straight away but starts after a few minutes . I also hear a kind of grinding noise when turning. Any ideas/solutions would be great thanks

    Alan

  2. #2
    Regular Member macdad's Avatar
    Join Date
    Dec 2007
    Location
    East Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sounds like a faulty pump to me,i assume you've checked the oil in the cannister m8.

  3. #3
    Regular Member bighammerfan's Avatar
    Join Date
    Sep 2008
    Location
    hillingdon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    No i haven't done anything yet. Im not very mechanical

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vectra C V6 3.2l problem
    By zer04 in forum Engine & Drivetrain
    Replies: 10
    Last Post: 12th October 2013, 08:34
  2. remember to take the stering lock off when towing lol
    By hoochydady in forum Comedy & Humour
    Replies: 1
    Last Post: 8th June 2011, 00:45
  3. Vectra wiper problem - any advice appreciated - Vectra C
    By newbreed in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 13th May 2011, 20:57
  4. Vectra c problem
    By S60LWD in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 2nd July 2010, 07:39
  5. Problem...? Vectra SXI...problem with starting after filling with fuel?
    By doozer in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 8th November 2008, 09:40

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •