User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Oil display and temp

  1. #1
    Regular Member
    Join Date
    Mar 2010
    Location
    Hertfordshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Oil display and temp

    I don't have a manual for the car (2.2 dti SRI)at the moment as I'm waiting for the dealership to get me one and when I turned off the car this evening it showed a spanner with an oil can and 1.0 Ltr which I'm assuming would mean add a litre of oil? am I right? Also It's the first diesel I've owned and was wondering which Oil I should be buying It's done 68'000 miles. Last but not least how quickly should these engines take to get up to temperature as It seems to take a while for the gauge to move?

  2. #2
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Diesels do take a while to heat up, allow about 10 mins really.

    Put what ever oil in as its already using really, if its a vx service history then its probably 5w30 unless the garage was cutting corners - in which case its anyones guess really.
    Now I need a turbo to keep up!

  3. #3
    Regular Member
    Join Date
    Mar 2010
    Location
    Hertfordshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Ok cheers, Is it normal for the dash to say that I need oil even though the level is actually spot on? I checked it earlier and it bang on the max mark if not a little black considering it was suppose to be changed 2 weeks ago!

  4. #4
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Oil with a spanner? Thats a service light, not a level light.

    Looks like they haven't reset the service. Have a search on here, i know the answer is about
    Now I need a turbo to keep up!

  5. #5
    Forum Moderator John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)

    Default

    The dti's take an age to heat up mate, it's normal

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Climate control temp display issue
    By Greebo in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 30th June 2012, 14:11
  2. Vectra C Radio/Time/Date/Temp Display Dead
    By KBW137 in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 4th September 2011, 23:29
  3. Annoying temp display
    By lencuff in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 19th January 2011, 00:48
  4. F in temp display
    By zafira in forum Diesel Engine related
    Replies: 6
    Last Post: 28th August 2010, 16:17
  5. temp display on radio display
    By MRunMotorsport in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 19th April 2010, 15:55

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •