User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: mpg and loud diesel noise

  1. #1
    Regular Member suggs1971's Avatar
    Join Date
    Feb 2009
    Location
    east cleveland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default mpg and loud diesel noise

    Hi all. I had the injector seals replaced and the inlet manifold cleaned a few weeks ago due to bad starting at times and mpg had dropped from 43 mpg to 37 mpg also a louder diesel noise under acceleration. My veccy has done about 500 miles since the jobs were done. Still a little bit bad to start but not as bad, coughs a little bit then a bit of smoke then runs ok (leak off pipes were done last year), mpg has gone up to 40.7, the louder diesel noise under acceleration is still there.
    Does anyone have any other ideas what could be the problem.
    Cheers for any advice. My veccy is a 2.0 dti 52 reg.

  2. #2
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    Try using injector cleaner. Might help. Change the fuel filter and treat the car for a full service while you're at it

    Our DTi knocks a bit when I accelerate and mpg wise, it's terrible.

  3. #3
    Regular Member suggs1971's Avatar
    Join Date
    Feb 2009
    Location
    east cleveland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Had a full service done in feb, tried some millers injector cleaner after i got the car back when the injector seals got done. Ive checked all pipes, egr valve/ boost sensor was cleaned last year, there is no eml on.

  4. #4
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    Might not be connected but...
    I serviced my old 3.0CDTi myself and I put a new fuel filter in Feb 2009. I used injector cleaner 2 months later and after 2 days of using the injector cleaner the car took a while to start from cold. I haven't replaced the fuel filter then but in Dec 2009 I discovered that the injector cleaner melted the crap away but blocked the filter.

    I suggest you try replacing the fuel filter again. Done ours today. Works a treat...engine runs better, smoother, stronger and is more efficient on fuel. The old filter was in less than 12months/15k miles.




    And clean the boost sensor. Made a huge difference when I cleaned it on our DTi + it's very easy to access, so it's not a hard job
    Good luck mate

  5. #5
    Ex-Staff Full Member John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    Quote Originally Posted by suggs1971 View Post
    Had a full service done in feb, tried some millers injector cleaner after i got the car back when the injector seals got done. Ive checked all pipes, egr valve/ boost sensor was cleaned last year, there is no eml on.

    Are you still using the millers?

  6. #6
    Regular Member suggs1971's Avatar
    Join Date
    Feb 2009
    Location
    east cleveland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yeah i only put 25ml of the stuff in the fuel tank when i had the injector seals done. My veccy started making the louder diesel noise about january time, vauxhall advised getting the injector seals done, but still the noise is there.

  7. #7
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra-c

    Trim : sri

    Engine : cdti

    Year : 2004

    Mileage : 98,000

    Default

    I would try the injector cleaner and the diesel filter, but most di/dti's do tend to have a little rattle especially when cold (so does the cdti), but the fact that you've done the inj seals and the leak off pipes would point toward the pump BUT don't go there while its running. Id just let it develop, the di/dti usually start straight away normally in hot or cold weather.

  8. #8
    Regular Member suggs1971's Avatar
    Join Date
    Feb 2009
    Location
    east cleveland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Diesel filter was done when i got the service done. Was gonna put the millers in once a month. The loud diesel noise is usually between 1000 rpm to 2000 rpm under load when driving but not when stationary and revving the engine. Only thing i could do i suppose is get my veccy on a diesel tuner as pump timing was mentioned to me by the mechanic who does a few jobs on my car. MPG has settled to 40.7 local driving. I did check a zafira forum where someone had the 2.0 dti engine and they said they had a old style diesel noise under acceleration and bad starting and they got the injector seals replaced which sorted it but hasnt with mine.

  9. #9
    Regular Member suggs1971's Avatar
    Join Date
    Feb 2009
    Location
    east cleveland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi all this is a list of what ive done myself and what the garage has done. Egr valve and boost sensor cleaned last year as eml was coming on at 70 mph. Recent full engine service, injector seals replaced, inlet manifold cleaned, millers injector cleaner added. Had the 'loud diesel noise' since january this year, this is when the mpg dropped. The mpg didnt change when i got the service done, stayed at 37 mpg. When i got the injector seals and inlet manifold cleaned the mpg went to the 41.4 then settled to the 40.7 it is on now, so not sure if the injector seals put the mpg back up or getting the inlet manifold cleaned put the mpg back up. There is no eml on. My veccy for about a year was doing 43 mpg on local driving then suddenly dropped in january.

  10. #10
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    Replace the diesel filter AGAIN. Had the same problem and it made a big difference on our 2.2DTi. The injector cleaner you used pushed the crap from the sistem into the new fuel filter. Diesel filters are not expensive so in my opinion it's worth a try And clean the boost sensor again. On our 2.2DTi it was all sooted up in just 5k miles

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loud sucking noise
    By D33ler in forum Engine & Drivetrain
    Replies: 3
    Last Post: 25th March 2012, 12:51
  2. LOUD grinding noise?
    By UncleMelon in forum Suspension, Wheels & Brakes
    Replies: 11
    Last Post: 11th January 2012, 11:21
  3. loud clunking noise
    By kristian in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 30th January 2010, 22:00
  4. Loud Screeching noise
    By lesbo in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 5th January 2009, 10:11
  5. Loud knocking noise...
    By haegwani in forum Suspension, Wheels & Brakes
    Replies: 2
    Last Post: 15th June 2007, 07:54

Visitors found this page by searching for:

how do you change fuel filter on zafira 2.0 dti 52reg

dti loud injectors

vectra dti loud injectors

diesel zafira sounds loud

vauxhall zafira noisy diesel pump

my diesel engine sounds loud vectra

astra diesel noisy

is opel vectra c diesel noisy

opel vectra 2.2 dti engine noise

vectra c 2.0 dti bad injectors

zafira diesel cracking noise under acceleration

vauxhall astra 2.0 diesel di noisy

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •