User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: 1.9 150

  1. #1
    Regular Member robk6112's Avatar
    Join Date
    Jan 2009
    Location
    Halifax
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 1.9 150

    Morning

    My 150 temp gauge never moved for the last 4 months. It has now suddenly started to work but the car feels slower under 2000 rpm? My egr valve has been done last year by the way. Any ideas? By the way I love my 150 and not here to slag it off!
    Last edited by robk6112; 26th March 2010 at 11:35. Reason: wrong info

  2. #2
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi

    Trim : XP1

    Engine : 1.9 CDTi 150

    Year : 2007

    Mileage : 66000

    Default

    Oddly mine has started to move recently, but its probably down to the fact I have the heater on cool now, rather than warm/hot - no difference in running though.

    Maybe your EGR needs a clean, alot can happen to them in a year.
    Swirls etc ok, a quick visual check will confirm.

  3. #3
    Regular Member P3tchy's Avatar
    Join Date
    Jan 2009
    Location
    Milton Keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    That will be the thermostate then, Needs replacing. and as soon as you do it will show up faults with the inlet manifold. Thats what happened to mine.

  4. #4
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi

    Trim : XP1

    Engine : 1.9 CDTi 150

    Year : 2007

    Mileage : 66000

    Default

    Quote Originally Posted by P3tchy View Post
    That will be the thermostate then, Needs replacing. and as soon as you do it will show up faults with the inlet manifold. Thats what happened to mine.
    Surely coincidence..?

  5. #5
    Regular Member robk6112's Avatar
    Join Date
    Jan 2009
    Location
    Halifax
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by P3tchy View Post
    That will be the thermostate then, Needs replacing. and as soon as you do it will show up faults with the inlet manifold. Thats what happened to mine.
    Ill get a new thermostat then. Inlet manifold have already had that done!

  6. #6
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi

    Trim : XP1

    Engine : 1.9 CDTi 150

    Year : 2007

    Mileage : 66000

    Default

    Thermostat wouldn't make the car sluggish under 2k.... my thermostat been the same since I got the car and its been fine.

  7. #7
    Regular Member P3tchy's Avatar
    Join Date
    Jan 2009
    Location
    Milton Keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Dan_BlackSRi View Post
    Surely coincidence..?
    The inlet manifold has a water jacket after the stat, No idea why, Maybe Diesels are more efficient with warm air on the intake.

    If the stat won't open then the inlet will never get warm (neither will the inside of the car)

  8. #8
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi

    Trim : XP1

    Engine : 1.9 CDTi 150

    Year : 2007

    Mileage : 66000

    Default

    Quote Originally Posted by P3tchy View Post
    The inlet manifold has a water jacket after the stat, No idea why, Maybe Diesels are more efficient with warm air on the intake.

    If the stat won't open then the inlet will never get warm (neither will the inside of the car)
    My needle never (ish) moves, but still gets snuggly inside pretty quick... maybe mine has a dodgy temp sender then

  9. #9
    Regular Member robk6112's Avatar
    Join Date
    Jan 2009
    Location
    Halifax
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats






  10. #10
    Regular Member P3tchy's Avatar
    Join Date
    Jan 2009
    Location
    Milton Keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If its for the 150 then yeah not bad, I paid £45 for mine inc vat. Theres a modified version but not sure on the part number. Just be careful your not buying old superceeded stock off ebay.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •