User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: Vectra C 04- Engine Fault

  1. #1
    Regular Member
    Join Date
    Mar 2010
    Location
    Canvey Island
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Vectra C 04- Engine Fault

    HI All

    Hope everyones doing well, this is my first post!!

    I have a 1.8 LS Petrol 2004 Vectra C

    The last month ive been getting a constant on & off problem. Every now and again in revs between maybe 1 - 3 the car will feel like it is being pulled back, and even with the foot down it is very laggy and doesnt want to go anywhere, then it will get to a point and go and the light comes on. Then after a while the light will go off and it will be ok for a while, then it all happens again.

    Does anyone know what this could be , and if there a cheap ( ???) diagnostics place to find out the fault and get it sorted.

    Many thanks

    Neil

  2. #2
    Ex Vec-C Admin Deztroyer's Avatar
    Join Date
    Jan 2009
    Location
    WGAF#5
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    you can read the fault code yourself with the brake pedal

    with your foot firmly on the accelerator and brake pedal turn the key to stage 2 (lights on dash) and watch the engine light in the bottom right corner it will start to flash, then stop flash again , stop flash again stop and flash again a total of four sets of flashes

    10 flashes -= 0
    1 = 1
    2= 2

    and so on

    you should then have a 4 digit code to work out the problem

    hth

    regards

    Dez

    0-Large smile ......every time it's driven

  3. #3
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    Quote Originally Posted by deztroyer View Post
    you can read the fault code yourself with the brake pedal
    It doesn't however work on every Vectra

  4. #4
    Regular Member cerbrious's Avatar
    Join Date
    Apr 2008
    Location
    Wigan
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    if the hesitation feels like a slight missfire its very likely to be the coil pack (about £60) but i would try a set of plugs first

  5. #5
    Regular Member
    Join Date
    Mar 2010
    Location
    Canvey Island
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi All,

    I done it on m,y Lunch break and it worked. I have
    10
    3
    10
    4

    Can someone point me in the right direction to finding out this fault please

    Thanks

    Neil

  6. #6
    Ex Vec-C Admin Deztroyer's Avatar
    Join Date
    Jan 2009
    Location
    WGAF#5
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    P0314. Single Cylinder Misfire (Cylinder not Specified)

    as above possibly coil or spark plug related

    0-Large smile ......every time it's driven

  7. #7
    Regular Member
    Join Date
    Mar 2010
    Location
    Canvey Island
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for your help on this, at least i have a rough idea of the problem when i take it in, it needs a service so ill get it all done in one go.

    This problem i have would it affect the fuel consumption??

    Ive only had the car about 6 months , but a full tank £60 and im just about reaching 400m, or is this the norm?

    Thanks again

    Neil

  8. #8
    Ex Vec-C Admin Deztroyer's Avatar
    Join Date
    Jan 2009
    Location
    WGAF#5
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    a misfire would mean the engine is not running at optimum performance and as such would affect your fuel consumption.....


    i wish i could get 400 miles to a tank - i'm closer to 230-300

    0-Large smile ......every time it's driven

  9. #9
    Regular Member
    Join Date
    Mar 2010
    Location
    Canvey Island
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    lol, so im over reacting then!

    Ive moved from a fiesta 1.25 where £30 would get me 300 miles..

    Thanks again for all your help0, ill get the service done first, if the problem persues ill look at the coil pack

  10. #10
    Regular Member kentish_bloke's Avatar
    Join Date
    Mar 2008
    Location
    Sittingbourne, Kent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : Elite

    Engine : 1.8 VVT

    Year : 2009

    Mileage : 42800

    Default

    Quote Originally Posted by Riches View Post
    Hi All,

    I done it on m,y Lunch break and it worked. I have
    10
    3
    10
    4

    Can someone point me in the right direction to finding out this fault please

    Thanks

    Neil
    P0304 - Cylinder 4 Misfire Detected

    Youll find all the codes here

    Personally i would try a set of new spark plugs first, much cheaper than a new coil pack. I got some Bosch Super 4 plugs, fitted them & got a misfire, which was confirmed by using the fault code reading method you used. I thought i would be buying a new coil pack, but put the original plugs back & the misfire disappeared, although it took a few days before the emissions light went out.

    I too have got a 2004 LS. I usually get around 400 miles to a tank full but that's some dual carriageway & motorway driving and some urban 30mph driving too, probably normal, but i have got the short SRI intake & have done the airbox mod.
    Last edited by kentish_bloke; 25th March 2010 at 16:45.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. engine fault please help
    By neill in forum Engine & Drivetrain
    Replies: 5
    Last Post: 7th August 2011, 06:28
  2. 2.0 dti engine fault
    By huddsy in forum Engine & Drivetrain
    Replies: 4
    Last Post: 8th April 2011, 21:36
  3. Engine Fault?? Need Help Please !!!
    By bigpaw35 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 6th August 2009, 21:47
  4. Engine fault ???????????????????
    By tony24 in forum Engine & Drivetrain
    Replies: 12
    Last Post: 21st April 2009, 18:11
  5. Engine Fault
    By bentleyboy in forum Engine & Drivetrain
    Replies: 2
    Last Post: 13th December 2005, 22:08

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •