User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: help plz

  1. #1
    Regular Member
    Join Date
    Nov 2006
    Location
    Belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused help plz

    i drive a 120bhp cdti 05 48000miles on it, below 1800rpm my car is really sluggish but once the turbo kicks in the car goes spot on is there any reason for this?

    the problem seems to occur in lower gears, i had a hestitation further up the rev range but that seems to have passed


    all help welcome
    Brian

  2. #2
    Regular Member nigec's Avatar
    Join Date
    Mar 2009
    Location
    barnsley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Start with egr valve and boost sensor as im haveing the same symptoms, just cleaned mine at weekend, make sure you clean the inside of manifold to where it bolts on.

  3. #3
    Ex-Staff Full Member John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    Sounds like the EGR valve either needs cleaned or replaced

  4. #4
    Regular Member
    Join Date
    Nov 2006
    Location
    Belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    sound guys ill have a wee look 2moro if i get the chance, i had it off not that long ago changin my heater plugs(nightmare) and it looked ok but ill get it off and have a look again sometime this week.

    Brian

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •