User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: Flat blade smear

  1. #1
    Regular Member ChrisBilly's Avatar
    Join Date
    Jul 2009
    Location
    The Rift, Cardiff
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Flat blade smear

    Fitted flat blade wipers today because my old ones smeared like mad, the new one works great wiping up but when it comes back down it smears quite bad! I've tried sliding the blade out from the spoiler and putting it back in the other way but its still the same. Is it just because they're cheap tesco ones or maybe the angle of the blade on the screen?

  2. #2
    Regular Member kentish_bloke's Avatar
    Join Date
    Mar 2008
    Location
    Sittingbourne, Kent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : Elite

    Engine : 1.8 VVT

    Year : 2009

    Mileage : 42800

    Default

    did it smear in the same place with the old wipers?

    have you used anything like rainx?

    my advice would be that its not the wipers at fault, you may have some contamination on the part of the screen where it smears. give it a good clean with a good quality screen cleaner or methylated spirit, plus give the blades a wipe with some meths too, to remove any mould release agent that may still be on the rubber blades.

  3. #3
    Regular Member AntB's Avatar
    Join Date
    Sep 2007
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats


    Trim : GSi

    Engine : 3.2 V6


    Mileage : 39k

    Default

    When it comes to wipers, I believe you get what you pay for. My Bosch Aero flatties work a treat.

  4. #4
    Regular Member chris1804's Avatar
    Join Date
    Oct 2009
    Location
    Sandwell
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    get bosch ones , there expensive but worth it

  5. #5
    Regular Member Ademusic's Avatar
    Join Date
    Dec 2009
    Location
    Dunstable
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Even though they're cheap ones, they should still do the job..if they're no good, I'd take them back..I've used cheap flatblades and still do and have never had a problem

  6. #6
    Regular Member badback's Avatar
    Join Date
    Jan 2009
    Location
    Runcorn
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I've tried 2 sets of the cheap ones, both were poo, so I've now got the Bosch ones, much better. £25 inc p+p.

  7. #7
    Regular Member mattv6diesel's Avatar
    Join Date
    Oct 2009
    Location
    portland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Bmw 330d

    Trim : Msport

    Engine : 3.0d

    Year : 2008

    Default

    they are expensive but what can you do as above cheap cause trouble

  8. #8
    Full Member neverlandandy's Avatar
    Join Date
    Sep 2006
    Location
    lanark
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia Elite Nav

    Trim : Elite

    Engine : 2.0 cdti

    Year : 2012

    Mileage : 9k

    Default

    i got a set of gm ones from the dealer think they were about £30 and what a load of crap they are i will be going back to standard ones soon

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rear Flat Blade?
    By victorM in forum Bodywork & Interior
    Replies: 7
    Last Post: 17th October 2009, 15:28
  2. Flat Blade Wipers
    By mpc in forum Vectra C / Signum Car Chat
    Replies: 17
    Last Post: 19th May 2008, 13:17
  3. GM Flat Blade Wipers
    By Mark The Cabby in forum Vectra C / Signum Car Chat
    Replies: 112
    Last Post: 28th January 2007, 20:00

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •