User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Yellow engine light staying on & engine getting hot.

  1. #1
    New Member
    Join Date
    Mar 2010
    Location
    Widnes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Yellow engine light staying on & engine getting hot.

    Good people out there...The yellow engine block light on my 2007 SRI CDTI 150ps has suddenly began to stay on today. Engine has also started to get hot, just over 90 degrees. Would think the two are related. New water pump fitted 1,500 miles ago No loss of coolant and def' no leaks! Cars done 98,000mls and has been regularly serviced at correct intervals. Any ideas what the problem is guys??? Any advice much appreciated.

  2. #2
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Are the fans comming on?
    Now I need a turbo to keep up!

  3. #3
    New Member
    Join Date
    Mar 2010
    Location
    Widnes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Thumbs up Yellow engine light staying on & engine getting hot.

    Hi Mate, thanks for your reply.
    No, the fans don't seem to be coming on. Temp won't go much over 90 degrees but fault only occurred this afternoon, so have only done around 5 miles since problem started. Do high miles (mainly m/way) so am scared about venturing out on Monday. Just spent megabucks on the car in last month on alternator, flywheel/clutch, cambelt & waterpump and a major 80,000 mile sevice just before all the problems started.
    Thanks again, Phil.

  4. #4
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I'd get it back to the garage that did the work as they may have knocked a plug out or something.

    Either that or you need to get the codes read.
    Now I need a turbo to keep up!

  5. #5
    New Member
    Join Date
    Mar 2010
    Location
    Widnes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Cheers fella. Thanks for the advice.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. yellow engine light staying lit
    By leedrummond in forum Vectra C / Signum Troubleshooting
    Replies: 7
    Last Post: 6th December 2012, 12:47
  2. Engine lumpy now Engine Management Light is on
    By Fitzy-2.0T in forum Vectra C / Signum Car Chat
    Replies: 24
    Last Post: 17th July 2012, 16:51
  3. Engine and Spanner Light Before I Start The Engine
    By corderz in forum Engine & Drivetrain
    Replies: 14
    Last Post: 24th March 2011, 18:48
  4. Replies: 3
    Last Post: 28th April 2009, 19:49
  5. yellow Engine light perm on dash !!
    By Ghosty621 in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 3rd December 2006, 04:20

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •