User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Fault code 3.0 V6CDTi

  1. #1
    Regular Member
    Join Date
    May 2008
    Location
    west yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Fault code 3.0 V6CDTi

    Car with Spanner light came on today, I did the pedal trick and got a fault code = 0370 Timing Reference High Resolution Signal A Malfunction, Can anyone tell me what it means?

  2. #2
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Crank sensor?
    Now I need a turbo to keep up!

  3. #3
    Regular Member
    Join Date
    May 2008
    Location
    west yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Crank sensor?
    dose ? mean it is or are you asking

  4. #4
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Neither, just wondering if its a possibility due to the "timing reference" in the fault code. Not sure if there are sensors on the cam's too.
    Now I need a turbo to keep up!

  5. #5
    Regular Member m8internet's Avatar
    Join Date
    Dec 2006
    Location
    Cumbernauld, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    There should be one sensor on the camshaft (non-critical) and crankshaft (critical)
    When the camshaft one fails the warning light will come on, but the engine will not normally go into safe mode (as it can use the crankshaft sensor)
    When the crankshaft sensor fails the engine will be put into safe mode

    From what I understand, P0370 is the fuel pump
    Given you have a 2005 Y30DT this suggests you have the updated EMS which actually reports faulty SCV

    How often does the warning light appear?
    If it is intermittent, leave it, until it becomes permanent

    Do you have a warranty?

    If you are lucky, it is just the sensor (about £100)
    If you are not, then you are looking at new SCV, or at worst a pump!

  6. #6
    Regular Member
    Join Date
    May 2008
    Location
    west yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The warning light has just come on today but its been on all day and its out of warranty

  7. #7
    Regular Member m8internet's Avatar
    Join Date
    Dec 2006
    Location
    Cumbernauld, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    When the warning light comes on, stop at the first available opportunity, and remove the key for at least one hour

    If the warning light comes back on straight away, there is a permanent fault, get the code read

    If the warning light does not come on, then monitor how often it comes on

    I had mine come on once the night before the last service, the engine went into safe mode, after the SCV had been replaced (was thinking "christ what now")
    Left the car overnight, reported it for service that it had come on the previous night (no codes stored) and it's never been on since

  8. #8
    Regular Member
    Join Date
    May 2008
    Location
    west yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The car has been stopped over night, just started it up 2 second's later the light came on, its sill revs up ok so I don't think its in safe mode. Need to take it for a blast to make sure.

  9. #9
    Regular Member m8internet's Avatar
    Join Date
    Dec 2006
    Location
    Cumbernauld, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Do NOT take it for a blast, if the sensor is at the end of its life then it may well put the engine into safe mode

    To see if it is in safe mode, simply rev and accelerate as normal
    If in safe mode you will notice a different tone to the engine on idle (revs may be slightly higher than normal to prevent stalling) and complete lack of "power" and difficulty getting any acceleration above 3000rpm

    As above, I have read this is simply the EMS not receiving a signal from the fuel pump and it should not go into safe mode
    Firstly it needs the code reading and diagnoses from TIS
    If it is indeed no signal from fuel pump, then visit a diesel specialist
    Sadly you will need to get your blankety blank cheque book out; minimum £1000 for a fuel pump repair, PLUS the labour swapping it!

  10. #10
    Regular Member
    Join Date
    May 2008
    Location
    west yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I did rev it this morning and it went past 4500rpm on idle revs seemed ok, Just got in it now and the starter is just clicking very slowly not even trying to turn over

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. fault code on vec c 1.8 sri please help
    By gavs-sri in forum Engine & Drivetrain
    Replies: 11
    Last Post: 10th April 2012, 21:52
  2. fault code help
    By madmanc in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 8th December 2010, 21:46
  3. fault code help pls
    By pipe rodder in forum Engine & Drivetrain
    Replies: 13
    Last Post: 1st October 2009, 20:19
  4. fault code
    By speedfreeride@yahoo in forum Engine & Drivetrain
    Replies: 1
    Last Post: 28th June 2009, 17:15
  5. HELP *Fault code* HELP
    By andymcniven in forum Vectra C / Signum Troubleshooting
    Replies: 7
    Last Post: 17th March 2009, 21:30

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •