User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: xenon self level motor problems

  1. #1
    Regular Member
    Join Date
    Nov 2009
    Location
    Luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default xenon self level motor problems

    hi, had trouble with the self level motor a week or so ago, got the headlight out and fitted the new one, all good, now the other one is setting itself too high all of a sudden, it might be where im going down hill and it kicks up and gets stuck? do i need another blooming motor? any ideas? if i turn engine off and on and corrects itself, cheers

  2. #2
    Regular Member
    Join Date
    Nov 2009
    Location
    Luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    bump

  3. #3
    Regular Member byebyeitsagsi's Avatar
    Join Date
    Jun 2008
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    First of all check all the connection are fully connected, including the ECU for the headlights. Mine never used to level at all, turned out it was unplugged at the ECU.

  4. #4
    Regular Member muffking's Avatar
    Join Date
    Nov 2006
    Location
    Lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    You could swap them over if you think it's getting stuck, or maybe just park facing a wall/fence and jack the back up so you see the lights go up & down when you turn the ignition on, then see if they drop when you lower the car.

    Either way Tech 2 can calibrate them by running them through the height levels before zero'ing them to the centre position, which would make sure that they are returning properly.

  5. #5
    Regular Member
    Join Date
    Nov 2009
    Location
    Luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    no well the o/s has gone really high and wont come down now, so thinkin its the sensor on the axle..... anymore ideas?

  6. #6
    Regular Member
    Join Date
    Jul 2009
    Location
    NEWPORT
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    My rear sensor was broken and it still moved but only one side i do have a brand new front axle one spare the cost of the rear is about £55 i got mine from ebay Germany for £20

  7. #7
    Regular Member muffking's Avatar
    Join Date
    Nov 2006
    Location
    Lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Again, a Tech 2 will pinpoint the problem when it does the calibration check. Cheaper than buying a sensor/motor in the hope that you get it 1st time?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Preface - A question about headlights level motor
    By superstuper in forum Electrical & ICE (including SatNav)
    Replies: 9
    Last Post: 26th April 2012, 10:16
  2. Headlight level motor
    By davidj387 in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 6th February 2012, 23:04
  3. Radio and oil level warning light problems
    By achapman in forum Electrical & ICE (including SatNav)
    Replies: 10
    Last Post: 9th March 2010, 19:44
  4. Rear wiper motor frustraing problems
    By woody in shetland in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 6th January 2010, 22:38
  5. Wiper motor problems **help**
    By parsco in forum Bodywork & Interior
    Replies: 11
    Last Post: 22nd April 2009, 18:29

Visitors found this page by searching for:

vectra c xenon motor location

vectra xenon leveling problem

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •