User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: car and spanner light 2003 Vectra 2.0dti help

  1. #1
    Regular Member
    Join Date
    Mar 2009
    Location
    Glasgow
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default car and spanner light 2003 Vectra 2.0dti help

    Hi All

    Over the last few days my car and spanner light has been randomly coming on and off while driving. When the light comes on the cruise control stops working. Car still runs smoothly when light is on

    I have read on some of the posts that it may be coming on due to water in the fuel filter so with the car not running I turned the valve on the bottom of the pump but all I got was a lot of gurgling, nothing came out.

    It didnt make any difference as the light is still randomly coming on and off while driving. It does not come on when you turn on the ignition, just when the car is driving.

    Can anyone advise please?
    Cheers
    David

  2. #2
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by circushead View Post
    I have read on some of the posts that it may be coming on due to water in the fuel filter
    I think that only applies to the 1.9 CDTi engines.

    Really need the fault code(s) read out. Too many things to start guessing.

    You might be able to do the pedal trick (see the how2) - failing that, it needs hooking up to a diagnostic fault code reader.

  3. #3
    Regular Member
    Join Date
    Mar 2009
    Location
    Glasgow
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thanks Dave
    Tried the pedal trick several times but it didnt work. Looks like I need to go to the dealer and spend money I dont have!

  4. #4
    Regular Member
    Join Date
    Jan 2009
    Location
    tyne and wear
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by circushead View Post
    Thanks Dave
    Tried the pedal trick several times but it didnt work. Looks like I need to go to the dealer and spend money I dont have!
    this might not be the problem but i had the 03 2.0dti and for some reason thought it would be good to put a cone airfilter on (noob) and i got the spanner light going off and on a little after i put it on. changed it back to normal and the light went away. so dont no if you done any minor mods recently or not was just a sugestion

  5. #5
    Regular Member
    Join Date
    Mar 2009
    Location
    Glasgow
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    the only thing that has been changed is the two front tyres. Dont know if the light was coming on before they were changed but wouldnt think changing tyres would have an impact.

  6. #6
    Regular Member
    Join Date
    Mar 2009
    Location
    Glasgow
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Light still coming on and off randomly. When it's on the car won't go above 3000 revs and the cruise control doesn't work. When it's off the everything is back to normal.

    I took out the air filter as I thought it might be something to do with airflow. The car is a 2003 (53) vectra with full vauxhall service history (50k miles). To me it looks like the air filter has never been changed. It was absolutely filthy with lots of dead flies etc on it. It also has a manufacturing date of 2003 on the filter itself. I need to take this back to vauxhall for a chat.

    Put a new filter in but the light is still going on and off randomly.

    Anyone have any more ideas?

  7. #7
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    have a look round the vac tubes for splits, check the pumps are working & get the codes read

  8. #8
    Regular Member macdad's Avatar
    Join Date
    Dec 2007
    Location
    East Midlands
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Check the two large black hoses on each side of the engine,and i mean have a good luck they are prone to splits.

  9. #9
    Regular Member
    Join Date
    Mar 2009
    Location
    Glasgow
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    All hoses etc look fine. I've got the car booked into my brothers friend garage tomorrow morning to get it plugged in and see what codes it gives out.

    I'll let you know the code(s) when I get them.

  10. #10
    Regular Member
    Join Date
    Mar 2009
    Location
    Glasgow
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Car is storing 1 code for the EGR valve.

    can anyone let me know where the EGR valve is On the 2.0dti so I cam try removing it Arne giving it a right good clean. A picture would be ideal.
    Cheers

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Car Spanner Light 2.0dti
    By holtie in forum Engine & Drivetrain
    Replies: 8
    Last Post: 17th January 2013, 16:37
  2. help! spanner light! 2.0dti
    By mick p in forum Engine & Drivetrain
    Replies: 67
    Last Post: 12th December 2010, 18:38
  3. spanner light on my Signum 2.0DTI..help pls
    By cermi in forum Engine & Drivetrain
    Replies: 2
    Last Post: 5th December 2009, 08:38
  4. 2.0dti - spanner light syndrome!
    By Littleted in forum Engine & Drivetrain
    Replies: 6
    Last Post: 10th January 2008, 00:23
  5. Signum 2.0DTI spanner light
    By signum_boy in forum Engine & Drivetrain
    Replies: 8
    Last Post: 17th May 2007, 22:00

Visitors found this page by searching for:

vauxhall astra 2.0 dti light with a car and spanner 2003

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •