User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: 2.0 Turbo problem

  1. #1
    Regular Member the stig's Avatar
    Join Date
    Sep 2009
    Location
    Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 2.0 Turbo problem

    My Brother has just bought a 07 2.0 turbo Its got the airbox mod and k&n filter, the problem is somtimes it pulls like a train and other times its sluggish, its only done 25k and has stamped up book any idea s what to look for or check There are no lights on dash and have done a diag check and its all clear

    Also Dont feel as quick as mine but feels smoother maybe because its on 17s and mines on 19s

  2. #2
    Forum Moderator John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    Personally I would have it on a rolling road to get the fault diagnosed

  3. #3
    Ex Vec-C Admin Deztroyer's Avatar
    Join Date
    Jan 2009
    Location
    WGAF#5
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    difficult to say without a fault light on = but you say its got a full service history ....but have they changed the spark plugs and replaced the filters....and what grade oils were used ??

    0-Large smile ......every time it's driven

  4. #4
    Regular Member
    Join Date
    Sep 2009
    Location
    Slovenia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by deztroyer View Post
    difficult to say without a fault light on = but you say its got a full service history ....but have they changed the spark plugs and replaced the filters....and what grade oils were used ??
    If I am correct, spark plugs need to be changed at 80K miles and his car has only 25K.
    My Vecy is also 07 2.0T (airbox with standard panel) and sometimes I have the same feeling as you describe. Sometimes pulls like a train other time nothing special). Didn't pay any attention to that because I was thinking it is all in my head

    Maybe there is some torque limiter when car is cold or something like that ?

  5. #5
    Ex Vec-C Admin Deztroyer's Avatar
    Join Date
    Jan 2009
    Location
    WGAF#5
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    most people on here will change their plugs every other service - i guarantee you if you tame them out one will be low

    0-Large smile ......every time it's driven

  6. #6
    Regular Member the stig's Avatar
    Join Date
    Sep 2009
    Location
    Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Have had the plugs out and they are all good Im thinkin it maybe a boost sensor or somthing?

    if you try set off from a standing start you can notice it alot more jeems to be struggling

    I was following him up to mine today and he siad he was kickin the S*** out of it and I was hardly moving there is definatly somthing a miss with it

  7. #7
    Regular Member Jezzy's Avatar
    Join Date
    May 2009
    Location
    S.E
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Dez....tell the man which valves to replace! lol

  8. #8
    Ex Vec-C Admin Deztroyer's Avatar
    Join Date
    Jan 2009
    Location
    WGAF#5
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    have a read of this thread

    it may assist you
    http://www.vectra-c.com/forum/showthread.php?t=101182

    0-Large smile ......every time it's driven

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2.2 dti Turbo problem
    By Shortland78 in forum Engine & Drivetrain
    Replies: 6
    Last Post: 18th February 2011, 14:34
  2. Turbo Problem
    By sberrow in forum Vectra C / Signum Car Chat
    Replies: 20
    Last Post: 12th March 2009, 21:01
  3. problem with turbo or ?
    By chikenbud in forum Engine & Drivetrain
    Replies: 3
    Last Post: 1st February 2009, 16:03
  4. Turbo Problem...
    By dankidd in forum Engine & Drivetrain
    Replies: 3
    Last Post: 11th August 2008, 22:55
  5. 2.0 DTI turbo problem
    By Vibez_Uk in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 19th March 2008, 21:15

Visitors found this page by searching for:

vectra c 2.0 turbo problemi

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •