User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 5 123 ... LastLast
Results 1 to 10 of 48

Thread: not pulling away good[loss of power]

  1. #1
    Regular Member Garfo's Avatar
    Join Date
    Feb 2010
    Location
    plymouth,devon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Angry not pulling away good[loss of power]

    hi all

    my 1.9 cdti sri 06 vec is not pulling away good, it goes at walking pace then if u rev it a alot the turbo kicks in
    not funny when ya tring 2 pull out when busy
    have done some reading on here and some people have cleaned there valves and other bit that goes onto it.


    garage has done this for me today costing £117 now the prob is still there

    so if i replace the chip thing that goes onto the valve will that cure it?
    if so where can i buy it?


    help me this car is driving me mad

  2. #2
    Regular Member Garfo's Avatar
    Join Date
    Feb 2010
    Location
    plymouth,devon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    anyone?

  3. #3
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    if there is lack of power below 2k rpm defo sounds like your EGR valve mate.

    If a good clean does not resolve then its time for a new one - sorry.

  4. #4
    Regular Member Garfo's Avatar
    Join Date
    Feb 2010
    Location
    plymouth,devon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    ok will try a new 1.is that all i should replace?

  5. #5
    On a Sabbatical
    Join Date
    Aug 2006
    Location
    EVERYWHERE
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Lack of power can also mean the dreaded 'swirl-valve' thing has reared its ugly head once again. I'm assuming that you have a 150 because the 120s don't have them?

  6. #6
    Regular Member Garfo's Avatar
    Join Date
    Feb 2010
    Location
    plymouth,devon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    yeah 150 m8
    whats that and where can i buy it?

  7. #7
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Was going to say the same.

    Could be an inlet failure - and specifically the Swirl flaps..

    basically the inlet is divided in two sections and swirl or tumble flaps allow flow between the two.

    These flaps can clog up for one, and also very common the bar on top of the inlet falls off due to wear in the ball joints holding the bar on. There is a motor that operates the flaps, but it actually only operates the 3rd flap and the others open as they are connected via this same bar, when it falls off the flaps can operate different and some not open.

    You get up and down movement in the tumble flaps due to the bearings in the flaps wearing, this then causes up and down movement on the flaps (shouldnt happen) meaning gunk can get through etc, and this is probabily the cause of the top bar falling off as the up and down movement wears the ball joints.

    In short - the fix is a new Inlet manifold and operating solenoid (plus EGR is recommended)

    Hope that kind of helps - I have a pic that will show you where this is., one sec

  8. #8
    Regular Member Garfo's Avatar
    Join Date
    Feb 2010
    Location
    plymouth,devon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    ok many thxs

  9. #9
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Pics as per explanation above:

    Engine with new inlet:


    Closer of Inlet showing top bar that is prone to fall off:


    Closer again of inlet showing inlet bar close up


    And even closer showing how the bar attaches to the top of the swirl / tumble flaps:


    Hope this helps again

  10. #10
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Dont let all this put you off tho mate - could still only be an EGR thats the first point of call..

    And also a check to see if the rod has fallen off the inlet.. If its still in place I would defo go with the EGR... if the bar is lying on its side off the swirls - thats a different matter

    CHeers

Page 1 of 5 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pulling Power
    By Quirrel in forum Engine & Drivetrain
    Replies: 5
    Last Post: 22nd December 2011, 19:48
  2. No power pulling off when cold??
    By digitalinkjetman in forum Diesel Engine related
    Replies: 6
    Last Post: 11th December 2011, 12:45
  3. lack of pulling power
    By garvey in forum Engine & Drivetrain
    Replies: 2
    Last Post: 2nd May 2009, 12:59
  4. Pulling Power - BP SUL - Tonight
    By VectraV6CDTi in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 2nd November 2007, 00:42
  5. more pulling power
    By Graham in forum Vectra C / Signum Car Chat
    Replies: 14
    Last Post: 9th January 2006, 12:45

Visitors found this page by searching for:

vectra c loss piwer when pulling off

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •