User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: hid's direct

  1. #1
    Regular Member dilan's Avatar
    Join Date
    Aug 2009
    Location
    dudley, west midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default hid's direct

    i had my passenger side hid fail on me this morning, so i contacted hid's direct and they told me to swap the ballasts over to see if it was the bulb or the ballast, which i did , it turns out to be a faulty ballast, which i've had to send back to them to test so they can replace it, my question is , have any of you guys had similar thing happen and if so how quick did they send you out the replacement part, cos for the time being i've only got one headlight and i really can't be bothered to swap it all back if it's only for a matter of days, the kit has only been fitted on my car for 3 weeks...thanks guys

  2. #2
    Regular Member leonvectrac's Avatar
    Join Date
    Sep 2008
    Location
    south shields
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    same happend to me, sent it off in a couple of days i had replacement, i just put my old bulb in until it arrived.

  3. #3
    Regular Member dilan's Avatar
    Join Date
    Aug 2009
    Location
    dudley, west midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for your reply,,I suppose I'll have to put my standard bulb back in then for a few days.... Have you had any further problems since you replaced the ballast in your's

  4. #4
    Regular Member leonvectrac's Avatar
    Join Date
    Sep 2008
    Location
    south shields
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i had a bulb warning light on the dash and thought it happend again but i moved the wires around a bit and it went off and its been ok since.

  5. #5
    Regular Member ahaz123's Avatar
    Join Date
    Oct 2009
    Location
    N. Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    same happened to me aswell... i sent the ballast back on the monday and had it returned on the friday. pretty quick! and no problems since

  6. #6
    Regular Member toughmat's Avatar
    Join Date
    May 2009
    Location
    Home Rhondda , Work in Cwmbran
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    same happened to me im sending mine of on monday

  7. #7
    Full Member Leemarksmith's Avatar
    Join Date
    Jun 2008
    Location
    Hanging Heaton / Batley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    19 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi (VXR Styling)

    Engine : Z19DTH (Re-mapped)

    Year : 04

    Mileage : 110k

    Default

    Same happened to nearly everyone thats fitted hids...

    Wonder how long they'll stay in business for just replacing everything every time...

  8. #8
    Regular Member
    Join Date
    May 2009
    Location
    Essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    HID Direct 50W 6000k in mine straight on 1st time and no issues since day1, suppose its just luck of the draw really which isn't great for product reliability but at least their aftersales service is working and rectifying problems had.

  9. #9
    Regular Member Handyandy-UK's Avatar
    Join Date
    Mar 2009
    Location
    Suffolk, Englandshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : BMW 525i

    Trim : SE Touring

    Engine : 3.0

    Year : 2007

    Default

    Quote Originally Posted by Steves-Vec View Post
    HID Direct 50W 6000k in mine straight on 1st time and no issues since day1, suppose its just luck of the draw really which isn't great for product reliability but at least their aftersales service is working and rectifying problems had.
    Ditto - 35W 6000K in mine and not even a hint of a problem to date.
    Might just be a bad batch of ballasts they've received - but to their credit they're replacing without argument. Wish more companies were as customer friendly.

  10. #10
    Regular Member shaun260589's Avatar
    Join Date
    Jun 2009
    Location
    Newcastle
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yeh got to admit i have never known a company that will just send out replacement parts straight away.

    and on another note no bother with mine with a month and bit of use

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. HID's Direct - Not impressed
    By John LE in forum Electrical & ICE (including SatNav)
    Replies: 65
    Last Post: 11th February 2011, 00:58
  2. hid's direct
    By ant6566 in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 10th February 2011, 20:16
  3. Who Delivers for HID's Direct?
    By mark1319 in forum Vectra C / Signum Car Chat
    Replies: 19
    Last Post: 15th December 2010, 14:15
  4. HID's Direct
    By John LE in forum Electrical & ICE (including SatNav)
    Replies: 64
    Last Post: 5th November 2010, 20:25
  5. HID's Direct
    By Graeme01 in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 2nd April 2010, 16:02

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •