User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: Lost confidence in my Vectra!!!!

  1. #1
    Regular Member connery-sri's Avatar
    Join Date
    Feb 2010
    Location
    Basildon, Essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Angry Lost confidence in my Vectra!!!!

    I have nearly had my 03 Vectra SRI a month and already it has needed an electric control module in the rear of the car.
    Then last nite, driving home from Wembley the ****** thing started to overheat. I stoped, let it cool and filled the rad up then set off. Not much later it started to overheat again and coolant light came on again.
    Called AA, apparently, could be possible thermostat, leaky pipes or head gasket. Had to get towed home and now taking it to an engine speacialist locally to see if that can actualy let me know whats wrong!!

    I loved the car when I got it but am now wishing I kept my old 3 series coupe, much more reliable.

    Anyone else have similar problems????

    So frustrated!!!!!

  2. #2
    Regular Member decks's Avatar
    Join Date
    Apr 2008
    Location
    nothern ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 2.0t btcc




    Default

    only have mine a week 05 sri 120 with 44000 needed new thermostat, plus a vibration in the clutch pedal hop not th DMF, but will drive it on to see what happens cant afford a new one just yet.

  3. #3
    Full Member Leemarksmith's Avatar
    Join Date
    Jun 2008
    Location
    Hanging Heaton / Batley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi (VXR Styling)

    Engine : Z19DTH (Re-mapped)

    Year : 04

    Mileage : 110k

    Default

    I have a 2.2, what was wrong with the module as my interior lights are playing up...

    Although i still think i may have just damaged the ribbon fitting the rear interior light

  4. #4
    Regular Member woody in shetland's Avatar
    Join Date
    Feb 2008
    Location
    Shetland Islands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Sxi

    Engine : 2.2 dti

    Year : 2002

    Default

    Hang in there bud, once she's running properly again you'll love her once more,
    Best of luck

  5. #5
    Regular Member connery-sri's Avatar
    Join Date
    Feb 2010
    Location
    Basildon, Essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Not exactly sure what was wrong with the module, symptoms on my car were a constant flashing n/s tail light, even when car parked etc. Sometimes the light would stay on all the time.

    I have heard it can cost around £500 for vx to fix although not sure what was paid as people I bought it from had it done at a local auto electrician!!!

    Good luck!!

  6. #6
    Regular Member shaun260589's Avatar
    Join Date
    Jun 2009
    Location
    Newcastle
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by connery-sri View Post
    Not exactly sure what was wrong with the module, symptoms on my car were a constant flashing n/s tail light, even when car parked etc. Sometimes the light would stay on all the time.

    I have heard it can cost around £500 for vx to fix although not sure what was paid as people I bought it from had it done at a local auto electrician!!!

    Good luck!!
    that was exactly the same as mine for rear control unit , part was £500 from vaux

    once ya car has got its niggles sorted out you will love it , there always seems to be something , let me show ya a wee couple of threads not long after i got it

    http://www.vectra-c.com/forum/showthread.php?t=91912

    http://www.vectra-c.com/forum/showthread.php?t=93306

  7. #7
    Regular Member
    Join Date
    May 2006
    Location
    n.ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    sorry to hear that bud but it is to be expected on a 7+ year old car, What do you expect? Any car that age will start to need work done.

  8. #8
    Regular Member 67688c's Avatar
    Join Date
    Apr 2008
    Location
    In UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by connery-sri View Post
    Not exactly sure what was wrong with the module, symptoms on my car were a constant flashing n/s tail light, even when car parked etc. Sometimes the light would stay on all the time.

    I have heard it can cost around £500 for vx to fix although not sure what was paid as people I bought it from had it done at a local auto electrician!!!

    Good luck!!

    May possibly be a faulty unit, but it's always worthwhile checking the large cluster of earth connections which bolt to the body just down inside the back of the boot. Loose or bad earth connections can give all sorts of wierd symptoms. Assuming you haven't already checked of course.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. lost keys for vectra im in the dog house
    By 6009tristanb in forum Vectra C / Signum Car Chat
    Replies: 15
    Last Post: 9th October 2011, 19:28
  2. HELP I have lost my confidence,,,
    By CLOMP in forum Vectra C / Signum Car Chat
    Replies: 25
    Last Post: 30th November 2010, 19:53
  3. Loosing confidence in my GSi!
    By byebyeitsagsi in forum Vectra C / Signum Car Chat
    Replies: 38
    Last Post: 23rd April 2009, 20:33
  4. Lost interest in me Vectra since being crushed
    By wickedwillie in forum Vectra C / Signum Car Chat
    Replies: 19
    Last Post: 27th December 2008, 04:22

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •