User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: CD70 Navi Volume Stuck

  1. #1
    Regular Member
    Join Date
    Apr 2008
    Location
    High Wycombe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Insignia

    Trim : SRI NAV

    Engine : 2.0 CDTI 140

    Year : 2013

    Mileage : 20000

    Default CD70 Navi Volume Stuck

    Hi all,

    Got in the car this morning and the radio was really loud. Tried turning it down via both the steering wheel controls and on the head unit but it just wont change.

    Tried all the settings, switched on/off via button, and ignition off/on again but still really loud.

    Has my unit had it? If so how much are these to replace and fit?

    Cheers.

  2. #2
    Regular Member Matty777's Avatar
    Join Date
    Jan 2010
    Location
    Nr Maidstone
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Dunno about the stuck volume, sounds weird but also fixable.

    If it came down to a new one, new they are (I think) about £1200 from Vxl, cheaper secondhand.
    But it would probably be best to put in something like a Pioneer aftermarket one, with SatNav, DVD, Ipod control, Bluetooth. Adapters available for the steering controls and the colour screen will still work for Board Computer etc etc. Prices vary but expect to pay about £600. Half Vxl's price and 2 x better.
    However, the above replacement is if your original is knakered, I don't know how to fix it, but doesn't really sound terminal.

  3. #3
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    Try doing what you would do if your PC played up. ie, reboot it. Disconnect and reconnect the power going to it.

  4. #4
    Regular Member
    Join Date
    Apr 2008
    Location
    High Wycombe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Insignia

    Trim : SRI NAV

    Engine : 2.0 CDTI 140

    Year : 2013

    Mileage : 20000

    Default

    Cheers for that.

    Just went out to the car and its now working perfect, didn't do anything!

    Put it down to Monday morning blue's.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. CD70 Navi Aux-In Volume issues
    By CooLix in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 13th June 2011, 14:39
  2. Please Help, cd70 navi is stuck on polish
    By soton in forum Electrical & ICE (including SatNav)
    Replies: 11
    Last Post: 17th March 2011, 22:26
  3. CD70 Volume Problem
    By anthonychall in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 27th August 2009, 19:00
  4. Cd70 sat nav volume
    By lochgilp in forum Electrical & ICE (including SatNav)
    Replies: 10
    Last Post: 15th January 2008, 11:33

Visitors found this page by searching for:

cd70 navi volume

cd70 volume not working

cd70 stuck in car

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •