User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: EGR on a 04 Reg 2.0lt diesel

  1. #1
    New Member
    Join Date
    Feb 2010
    Location
    Lincoln
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default EGR on a 04 Reg 2.0lt diesel

    Hi All,
    I'm new on here, so any help you can give would be great!
    I've been having problems with loss of power, I've been told its the EGR by dealer, and said it will cost £500+ to fix with a new one. Can it be cleaned on this model. I've had all the rubbers replaced, so its no them.

    Thanks
    raylincs

  2. #2
    Regular Member Dazzy2006's Avatar
    Join Date
    Dec 2009
    Location
    Notts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats






  3. #3
    Full Member bobssignum's Avatar
    Join Date
    Dec 2007
    Location
    polishing something or other somewhere
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum 2.0 DTi

    Trim : Elegance/Elite

    Engine : 2.0DTi

    Year : 2003

    Mileage : 73350

    Default

    Firstly name and shame the dealer £500 + to replace an egr is a huge rip off , what indication ,s did the dealer give you to point to the egr needing to be replaced , :ie what fault codes were quoted . more often than not dealers will go for the most expensive option with the hope of making an easy profit when the fault is something cheap and easy to fix.
    Driving vauxhall,s for 30 + years
    and still loving it

  4. #4
    New Member
    Join Date
    Feb 2010
    Location
    Lincoln
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Dazzy2006 View Post
    Hi Dazzy2006
    Thanks for infor and the how 2 link, Cleaned the erg, (wasn't too dirty), but still having same problem, I rev to just over 2000 revs, then the revs go up 500 then drop back down to 2000 (this is when warm) all the time. Checked rubber pipes for splits, (vauxhall charged me £87 for changing 1 and putting it through the diagnostics). Checked and blown through the pipes. Anything else anyone can think of?

    Thanks

  5. #5
    New Member
    Join Date
    Feb 2010
    Location
    Lincoln
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by bobssignum View Post
    Firstly name and shame the dealer £500 + to replace an egr is a huge rip off , what indication ,s did the dealer give you to point to the egr needing to be replaced , :ie what fault codes were quoted . more often than not dealers will go for the most expensive option with the hope of making an easy profit when the fault is something cheap and easy to fix.
    Hi bobssignum
    I'll let you know about the fault code tomorrow and I'm going to ask for the readout, see above what I've tried.
    Anyone know of someone else I can try around Lincoln, if everything I try doesn't work.
    Thanks

  6. #6
    New Member
    Join Date
    Feb 2010
    Location
    Lincoln
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    When cleaning the EGR the Manifold has a lot of black deposits
    Just thought I'd add that.

    Thanks

  7. #7
    Regular Member Dazzy2006's Avatar
    Join Date
    Dec 2009
    Location
    Notts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    when my egr went i took it to special diagnostic services in newark who charged £30 to read the codes but i kept getting the spanner and limp home mode along with poor accelaration below 2000 revs but only after the car warmed up.

    I bought my replacement egr from ebay but it wasnt cheap - £220

    http://cgi.ebay.co.uk/ws/eBayISAPI.d...m=330403635611
    Last edited by Dazzy2006; 21st February 2010 at 13:05.

  8. #8
    New Member
    Join Date
    Feb 2010
    Location
    Lincoln
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi again all
    Took my car back to main dealer, said the EGR fault was now clear (took it off and cleaned it, like it said in How To, thanks). But now it say's I've got a fault on the MAF sensor, they have said try and find someone with similar car and swap it and try before buying a new one. So trying to find someone local. If someone has any other ideas what the problem might be.

    Thanks

  9. #9
    Admin & Merchandise Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    58 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : insignia

    Trim : irmscher

    Engine : 2.0 cdti

    Year : 2009

    Default

    Try cleaning the MAF sensor

    Irmscher Insignia CDTI 130

    MOD'S...Irmscher front spoiler, Irmscher mats, Irmscher door pins, Irmscher rear spoiler, Irmscher grille, Irmscher skirt & exhausts,Irmscher Roof spoiler MOD'S TO COME..Side skirts,Wheels

  10. #10
    Regular Member Dazzy2006's Avatar
    Join Date
    Dec 2009
    Location
    Notts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    as above, use carb cleaner to clean the maf. 10-15 minute job

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Slight diesel leak from Diesel filter housing :-(
    By rollercoaster63 in forum Engine & Drivetrain
    Replies: 1
    Last Post: 22nd July 2015, 21:18
  2. V POWER DIESEL Vs DIESEL
    By OSSY in forum Vectra C / Signum Car Chat
    Replies: 30
    Last Post: 1st December 2009, 21:22
  3. BP Ultimate Diesel vs Morrison's mucky Diesel
    By Big Knox in forum General Chat
    Replies: 5
    Last Post: 31st March 2009, 13:11
  4. Shell Diesel Extra Or BP Ultimax Diesel
    By tonyx420 in forum Vectra C / Signum Car Chat
    Replies: 24
    Last Post: 11th July 2007, 13:25
  5. 2.0 Diesel
    By cp123 in forum Troubleshooting
    Replies: 12
    Last Post: 17th December 2006, 23:50

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •