User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: 2.2dti help needed

  1. #1
    Regular Member mooney's Avatar
    Join Date
    Sep 2007
    Location
    North west
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : VXR

    Engine : 2.8 v6 turbo

    Year : 06

    Default 2.2dti help needed

    when driving along if the revs go above 2.5k in 4th or 5th the spanner light comes up and it looses all power, pain in the arse if your joining a motorway or overtaking someone,
    if i turn the ignition off and back on the service light goes off and everything as long as i keep it below 2.5k
    its under warranty but until the engine management light comes on and stays on they don't know what it is and cant fix it,
    anyone got any ideas?

  2. #2
    Regular Member shaun260589's Avatar
    Join Date
    Jun 2009
    Location
    Newcastle
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hello mate could be one of a few things but before you start jumping to great expense three things to do

    1.clean the boost sensor
    2. clean the EGR valve
    3. check the hoses for air loss

    Just use the search bar at the top and you will find plenty how2's and guides
    Last edited by shaun260589; 19th February 2010 at 01:43. Reason: Beer fingers

  3. #3
    Forum Moderator John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    To elaborate on shauns answer check all of the small vacuum pipes (thin plastic pipes with rubber ends, emphasis on the rubber ends as they are normally the bit to split)

    Also check the large boost hoses, there is one that comes from the turbo down to the intercooler and one from the intercooler up to the inlet pipe. These pipes start to rot with the oil vapour from the turbo (they are pretty thin walled)

  4. #4
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    The damn thing went into limp mode about 1000 times today on the motorway. On-off-on-off...even just a flicker of the spanner light caused power loss. OP-COM showed boost sensor fault code so cleaned the sensor and all is well

  5. #5
    Regular Member shaun260589's Avatar
    Join Date
    Jun 2009
    Location
    Newcastle
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by john.robertson2 View Post
    To elaborate on shauns answer check all of the small vacuum pipes (thin plastic pipes with rubber ends, emphasis on the rubber ends as they are normally the bit to split)

    Also check the large boost hoses, there is one that comes from the turbo down to the intercooler and one from the intercooler up to the inlet pipe. These pipes start to rot with the oil vapour from the turbo (they are pretty thin walled)
    Can you tell John is a million times more technical than me?

  6. #6
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    Quote Originally Posted by shaun260589 View Post
    Can you tell John is a million times more technical than me?
    It's called experience with the DTi misery lol

  7. #7
    Forum Moderator John LE's Avatar
    Join Date
    Oct 2008
    Location
    Forfar, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Facelift Insignia/Corsa D

    Trim : LE/VXR

    Engine : 2.0 cdti/1.6 Turbo

    Year : 13/07

    Default

    Quote Originally Posted by Celes View Post
    It's called experience with the DTi misery lol
    Yep thats me DTi owned lol

    I always forgive it though as I love the dti engine

  8. #8
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    Quote Originally Posted by john.robertson2 View Post

    I always forgive it though as I love the dti engine

    Love it too! Goes on forever and likes it rough ............... lol

  9. #9
    Regular Member mooney's Avatar
    Join Date
    Sep 2007
    Location
    North west
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : VXR

    Engine : 2.8 v6 turbo

    Year : 06

    Default

    thanks for the advice guys
    had a quick look today and here's the engine without the cover

    is this the egr? (to the right of the dipstick) and do i just disconnect the 2 pipes going into it?

    i found 2 split end pieces marked with yellow electrical tape, anyone know part number or what there called?

    one of the pipes went to the black thing with a plunger type thing,

    and the other went, the black pipe

    can someone please circle the boost sensor please

  10. #10
    Regular Member Daywalker's Avatar
    Join Date
    Aug 2007
    Location
    Kaunas raj
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Qashqai

    Trim : Visia

    Engine : 1.5dci

    Year : 2010

    Default

    The two pipes you have wrapped in yellow tape are the vacumm hoses you just need to go to a motor factors and buy a length of vacumm hose and cut it to size.
    Attachment 29296
    Boost sensor is circled in yellow you have to disconnect the plug and then undo torx bolt ( being carefull not to drop it) then take out sensor and if is black (sooted up ) then get some wd40 and a small paintbrush and clean very carefully you are looking for a little bulb that looks like a grain of rice HTH

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 2.2dti oil change help needed
    By Allenglish2003 in forum Engine & Drivetrain
    Replies: 12
    Last Post: 12th August 2012, 20:45
  2. 2.2dti
    By tomo610 in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 24th August 2011, 16:33
  3. Max bhp 2.2DTi
    By JWBakkum in forum Diesel Engine related
    Replies: 31
    Last Post: 5th November 2010, 18:48
  4. What is a decat? 2.2dti advice needed....!
    By nim-nim in forum Diesel Engine related
    Replies: 3
    Last Post: 9th July 2010, 23:11
  5. Help needed from 2.2dti owners please
    By JudgeApocalypse in forum Vectra C / Signum Car Chat
    Replies: 21
    Last Post: 27th April 2009, 11:11

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •