User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 5 123 ... LastLast
Results 1 to 10 of 49

Thread: 2litre turbo emissions light problem...aaaargh

  1. #1
    Regular Member voxpop's Avatar
    Join Date
    Oct 2006
    Location
    cumbria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 2litre turbo emissions light problem...aaaargh

    hey all.....been a bit since ive been on......so F me off if you like

    i have a 2004 vec 2.0 turbo with 60k miles on it.....great car BUT my emissions light has come on and was told it would be the EGR valve......

    having read through a lot of the threads regarding my car and the egr apparently it DOES'NT HAVE 1........lol


    whats the best advice? put the car on a computer......or is it something easy i could try?????

    ive run the car on super unleaded with redex 1st just to see if it would help but it didnt....ive taken the battery earth off and reset everything but after 30 miles the emission light came back


    help please...i'm a mechanical cabbage

  2. #2
    Regular Member voxpop's Avatar
    Join Date
    Oct 2006
    Location
    cumbria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    oh and ive suffered no power loss/get home mode problems and the car SEEMS to run ok

  3. #3
    Ex Vec-C Admin Deztroyer's Avatar
    Join Date
    Jan 2009
    Location
    WGAF#5
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    could be whats described as a soft fault - would be wotrh while doing the brake pedal test and reading the code that way

    cheaper than a dealer

    0-Large smile ......every time it's driven

  4. #4
    Regular Member voxpop's Avatar
    Join Date
    Oct 2006
    Location
    cumbria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    brake pedal test?????? lol should i ask the cabbage question here or not?

    whats that then?

  5. #5
    On a Sabbatical
    Join Date
    Oct 2009
    Location
    rhyl
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hi mate reset the battery as mine comes on every so often,once my lamba sensor wire had been dragging which put the light on kwik fit recrimmped the wire £10 no more light when i bought the car back the light was on did brake accelerator test was a egt sensor £107 from vauxhall 30 mins later no more light,

  6. #6
    On a Sabbatical
    Join Date
    Oct 2009
    Location
    rhyl
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    make sure ignition is off press the brake and accelerator pedal keep them pressed turn the ignition on and count the flash ie 10 flashes = 0 so it just flashed 10 times 0 then it flashes six times 6 then flashes four times 4 then it flashes 5 times your code is 0645 then put a p in front so it would be p0645

  7. #7
    Regular Member voxpop's Avatar
    Join Date
    Oct 2006
    Location
    cumbria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    so how do i perform this test then? £107 holy crap thats a cumbrian years wage


    ive had no spluttering or smells or stalling....nothing....it just came on 1 day as i fixed my bonnet catch which had seized up

  8. #8
    Regular Member voxpop's Avatar
    Join Date
    Oct 2006
    Location
    cumbria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks mate i will try that then......i was thinking i could maybe get away with spending £0

  9. #9
    On a Sabbatical
    Join Date
    Oct 2009
    Location
    rhyl
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i would reset battery first,make sure you have the radio code,dissconnect both terminals rub them together,reconnect not sure if it makes a difference rubbing but i have always done it then no more light unles there was a faut,mine was on today after standing reset battery put back on light gone

  10. #10
    Regular Member voxpop's Avatar
    Join Date
    Oct 2006
    Location
    cumbria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    erm.....so what flashes then? brake light? something on the dash?


    told you...i'm useless at car maintenance

Page 1 of 5 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Location of the egr valve on a vectra c 2litre turbo 07 plate
    By davedave in forum Engine & Drivetrain
    Replies: 2
    Last Post: 12th September 2012, 21:18
  2. Vectra c 2litre turbo throttle body and idle air valve , clean
    By davedave in forum Engine & Drivetrain
    Replies: 4
    Last Post: 10th September 2012, 21:11
  3. vectra c 2litre turbo idle problem and engine cut out HELP
    By davedave in forum Engine & Drivetrain
    Replies: 4
    Last Post: 8th September 2012, 20:59
  4. emissions light on
    By johnnyw in forum Vectra C / Signum Troubleshooting
    Replies: 3
    Last Post: 9th February 2011, 11:03
  5. Aaaargh, it's got me.
    By AndrewTi in forum General Chat
    Replies: 15
    Last Post: 23rd December 2007, 23:19

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •