User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Erratic temperature reading

  1. #1
    Regular Member Gazza36's Avatar
    Join Date
    Jan 2010
    Location
    Cornwall
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Erratic temperature reading

    Hi, basically the engine temperature gauge takes ages to get up to about 40C then will drop down to zero and then might creep up again. The garage didn't have time to look at it properly but what they did say after plugging it in was that the computer showed 50C but the gauge showed nothing. I put a new sensor in before this and the heater blows warmish air so I'm a bit lost as to what to do. Is there any way of testing the thermostat without taking it out?

    I unplugged the sensor whilst the car was running to see if that sensor fed the gauge and I've now ended up with a spanner icon on the dash that won't go away even after disconnecting the battery. Any help appreciated. Gaz.

  2. #2
    Admin & Membership Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    75 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : insignia

    Trim : irmscher

    Engine : 2.0 cdti

    Year : 2009

    Default

    Mines the same mate on a long drive it will reach 80 then slowly start to creep back to 0 lol ive changed temp sensor not sure if thermostat would make it do this ?

    Irmscher Insignia CDTI 130

    MOD'S...Irmscher front spoiler, Irmscher mats, Irmscher door pins, Irmscher rear spoiler, Irmscher grille, Irmscher skirt & exhausts,Irmscher Roof spoiler MOD'S TO COME..Side skirts,Wheels

  3. #3
    Regular Member Gazza36's Avatar
    Join Date
    Jan 2010
    Location
    Cornwall
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi, I'm tempted to just change the thermostat regardless but I think it's dealer only at around £40. Do you think I need a diagnostics tool to clear the spanner? Gaz.

  4. #4
    On a Sabbatical
    Join Date
    Oct 2009
    Location
    lincoln
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    same as mine been told thermostat would get it right.

  5. #5
    Regular Member JockMcMann's Avatar
    Join Date
    Dec 2009
    Location
    scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    would also like to know how to get rid of that spanner light mine came on after spraying in that 10k boost cleaning stuff, it only stays on for a minute or two and then gose out but its doing my head in tryed disconnecting the battery and no joy

  6. #6
    Regular Member John35's Avatar
    Join Date
    Jun 2007
    Location
    in a white box
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Spanner light goes out after approx 30 starts or so (indicates a stored fault)

  7. #7
    Regular Member JockMcMann's Avatar
    Join Date
    Dec 2009
    Location
    scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by John35 View Post
    Spanner light goes out after approx 30 starts or so (indicates a stored fault)

    Thanks john

  8. #8
    Admin & Membership Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    75 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : insignia

    Trim : irmscher

    Engine : 2.0 cdti

    Year : 2009

    Default

    Quote Originally Posted by andy_hare View Post
    same as mine been told thermostat would get it right.
    Same as mine mate ?

    Irmscher Insignia CDTI 130

    MOD'S...Irmscher front spoiler, Irmscher mats, Irmscher door pins, Irmscher rear spoiler, Irmscher grille, Irmscher skirt & exhausts,Irmscher Roof spoiler MOD'S TO COME..Side skirts,Wheels

  9. #9
    Regular Member paul wingnut's Avatar
    Join Date
    Mar 2009
    Location
    durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra sri 150


    Engine : 1900 cdti 150

    Year : 2008

    Default

    mine never used to reach 70 changed thermostat totaly different now runs better hotter and more mpg

  10. #10
    Regular Member
    Join Date
    Dec 2009
    Location
    cardiff
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    if you dont want to change the whole stat, buy an insert basically just the stat part itself not the housing, Firstline make them part number is FTK063 cost me about 6 quid as opposed to 50 for the complete thing (that was for the 1800 petrol).

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Engine Temperature Reading
    By GerryB74 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 3rd January 2012, 21:23
  2. Outside temperature reading high?
    By zetecor in forum Electrical & ICE (including SatNav)
    Replies: 11
    Last Post: 10th March 2011, 02:48
  3. Temperature Gauge reading - AGAIN!
    By DurhamRed in forum Engine & Drivetrain
    Replies: 4
    Last Post: 26th September 2010, 18:01
  4. What's the lowest temperature reading
    By garvey in forum General Chat
    Replies: 11
    Last Post: 3rd March 2009, 11:27
  5. Temperature Reading gone with Bumper Fix!
    By globalpeace in forum Vectra C / Signum Troubleshooting
    Replies: 8
    Last Post: 17th July 2008, 21:20

Visitors found this page by searching for:

vectra c engine temperature erratic

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •