User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Bad design or just poor quality?

  1. #1
    Regular Member sol's Avatar
    Join Date
    Oct 2008
    Location
    Farnborough
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Bad design or just poor quality?

    Like at lot of others my Signum seems to have succumbed to the dreaded suspension squeak when going over speed bumps. By the sounds it the cold weather has something to do with it.

    I'm a bit loathed to start changing ARB's and drop links if the same thing is going to happen next year!!!!

    Vauxhall must have had enough people taking their cars in for this for them to have done something about it.

    Don't get me wrong, it's a great car, just embarassing, I'm sure pedestrians must be able to hear it. This my first VX having run Citroens for the past 20 odd years with absolutely no probs!!!

    Rant over, what does everyone else think?

  2. #2
    Moderator & Events Assistant paulhb's Avatar
    Join Date
    Dec 2007
    Location
    Wondering lonely as a cloud
    Post Thanks / Like
    Mentioned
    20 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    20 Post(s)
    Tagged
    0 Thread(s)

    Default

    How many miles has your motor done mate it is a common problem some folks have sprayed silicon lubricant on their ARB to see if it shuts up and the drop links are about £20 a pair my car needs new ones but it is 4 1/2 years old with 55,000 miles so not bad really and it takes 15 mins a side to swap them out.

  3. #3
    Regular Member sol's Avatar
    Join Date
    Oct 2008
    Location
    Farnborough
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    It's 55 plate 2.0 T with 30k on the clock. It's also got 19" snowflakes on, so not only am I swerving all over the place to avoid all these potholes, I'm also trying to avoid ant roads where are speed bumps.............not very easy these days!!!!!

  4. #4
    Regular Member
    Join Date
    Jan 2009
    Location
    scotland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    iv gt the same annoying squeak from the rear lol

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My poor poor veccy :(
    By tammyman09 in forum Vectra C / Signum Car Chat
    Replies: 17
    Last Post: 9th June 2011, 10:46
  2. CD70 Poor radio quality on AM
    By si69b in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 15th April 2011, 20:02
  3. Poor Design ?
    By FIL 4822 in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 12th July 2007, 20:55
  4. Poor Quality - First Photos Signum
    By DesignforLife in forum Quick Photo Album
    Replies: 11
    Last Post: 23rd January 2007, 14:49
  5. My Poor Poor Signum
    By Brake buster in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 30th September 2005, 15:45

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •