User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: Loss of power randomly on a SRi 150

  1. #1
    Regular Member jrwilshire2003's Avatar
    Join Date
    Dec 2009
    Location
    Bridgend
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Loss of power randomly on a SRi 150

    Hi all,
    Basically tried to get my car out the drive this morning and it stuggled like hell to get any revs up. Put your foot to the floor and it revved really slowly until about 2500 when it kicked in and was fine. Drove it for it a while. Stopped and started off again and it felt like there was no power then at 2000rpm it was fine again. Also a couple of days ago was driving on the motorway at 75 with cruise control on and it shut off my cruise control and again there was no power for about 10 secs then it would kick in again. This flagged up the spanner light so I'm hoping a fault is logged. I know my next step is to get the codes read but has anyone else had this??

  2. #2
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    Sounds like the EGR valve as this affects the low down (under 2000rpm) power. As you say it kicks in over 2,500rpm sometimes this leads me to think the swirl flaps are jammed opened (take engine cover and have a look down behind the fuel rail and see if the rod has broken off).

    Gazza4

  3. #3
    Regular Member jrwilshire2003's Avatar
    Join Date
    Dec 2009
    Location
    Bridgend
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Indeed a couple of months ago the rod had fallen off but did the repair on here. Had a look today and it's still on and operates fine and moves freely so I ruled that one out. It's odd as it had no power at all when I tried to get it off the drive in 1st!. Would just creep up slowly.

  4. #4
    Regular Member jrwilshire2003's Avatar
    Join Date
    Dec 2009
    Location
    Bridgend
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quick update. I have a cheapy Handheld scanner and it has come up with fault code P0400 which from looking on the net is a EGR Fault? Only gives me a code not a full description. Guessing a new EGR Valve is on the cards.

  5. #5
    Regular Member jrwilshire2003's Avatar
    Join Date
    Dec 2009
    Location
    Bridgend
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    New EGR Valve turned up today and has sorted the problem. Thanks again all. Onto the power steering problem now! <hehe>. Thanks!

  6. #6
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra-c

    Trim : sri

    Engine : cdti

    Year : 2004

    Mileage : 98,000

    Default egr

    glad to hear your sorted, well done.

  7. #7
    Regular Member Garfo's Avatar
    Join Date
    Feb 2010
    Location
    plymouth,devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by jrwilshire2003 View Post
    Quick update. I have a cheapy Handheld scanner and it has come up with fault code P0400 which from looking on the net is a EGR Fault? Only gives me a code not a full description. Guessing a new EGR Valve is on the cards.

    how much was that m8 and what year was ya car?

  8. #8
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    Glad its sorted m8

    Gazza4

  9. #9
    Regular Member jrwilshire2003's Avatar
    Join Date
    Dec 2009
    Location
    Bridgend
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    car is a 2004 plate. New valve was £90 off ebay. Genuine GM part.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 17
    Last Post: 11th March 2015, 00:55
  2. please help,dti loss of power
    By postman111 in forum Vectra C / Signum Troubleshooting
    Replies: 0
    Last Post: 23rd November 2011, 21:41
  3. loss of power
    By rick1965 in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 17th October 2010, 15:54
  4. loss of power
    By iansfocus in forum Engine & Drivetrain
    Replies: 5
    Last Post: 6th October 2010, 23:37
  5. Loss of power
    By BaileySRI in forum Engine & Drivetrain
    Replies: 8
    Last Post: 6th February 2010, 18:18

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •