User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Climate control

  1. #1
    Regular Member
    Join Date
    Jan 2010
    Location
    Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Climate control

    After having my Elite for a day, I've noticed that the fan on my climate control doesn't appear to blow as hard as the Mrs' SRi manual system.

    For instance, if I use the front demist button on both cars, the SRi is clearly better than mine. You can't hear yourself think the blowers are that loud.

    Also at maximum (7 I think) and the blowers set to front exit its not really very strong. Whereas the SRi would make my eyes water!

    Do I have a problem, or is this just a characteristic of the climate control system?

  2. #2
    Regular Member no1golfer's Avatar
    Join Date
    Jul 2009
    Location
    newcastle upon tyne
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i have the elite also and find its like your wife's car,very loud and blows you away.may need a re-gas or something,i think kwik-fit or national do a free check.

  3. #3
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Pollen filter blocked? It could be restricting the air flow.
    Now I need a turbo to keep up!

  4. #4
    Ex Vec-C Admin ed taylor's Avatar
    Join Date
    Oct 2005
    Location
    Looking Through a Camera Lens.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : Elite

    Engine : 3.2 V6

    Year : 04

    Mileage : 000

    Default

    Mine blows hard and fast too. Is your pollen filter blocked up with "muck" I wonder if a restricted inflow of air would cause this "effect". Also when you manualy turn the "big" central "knob" up to full blow doest that make any difference from say speed 3. You can manualy adjust the fan speed with the central "knob" this might give an indication if the fan is working proporly.
    I would check the drain holes by the pollen filter to see if they are blocked whilst you are "looking" at your motor, as if water gets into the heater motor or resistor pack it can cause problems.
    Last edited by ed taylor; 13th February 2010 at 15:45.

  5. #5
    Regular Member
    Join Date
    Jan 2010
    Location
    Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I'll have a butchers at the pollen filter in a bit, will report back with findings.

  6. #6
    Regular Member
    Join Date
    Jan 2010
    Location
    Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Had a quick look.

    Pollen filter. (I think it needs replacing lol)



    Is this the drain hole? It was full of gunk.


  7. #7
    Regular Member
    Join Date
    Jan 2010
    Location
    Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by ed taylor View Post
    Mine blows hard and fast too. Is your pollen filter blocked up with "muck" I wonder if a restricted inflow of air would cause this "effect". Also when you manualy turn the "big" central "knob" up to full blow doest that make any difference from say speed 3. You can manualy adjust the fan speed with the central "knob" this might give an indication if the fan is working proporly.
    I would check the drain holes by the pollen filter to see if they are blocked whilst you are "looking" at your motor, as if water gets into the heater motor or resistor pack it can cause problems.
    Turning the big knob does mke a difference yes.

    When I use the recirc button it does apper to blow much faster. It just sounds like its muffled inside the dsh somewhere when changing airflow about. There is a definate sound as if motors that change the flow are working, though.

  8. #8
    Ex Vec-C Admin ed taylor's Avatar
    Join Date
    Oct 2005
    Location
    Looking Through a Camera Lens.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : Elite

    Engine : 3.2 V6

    Year : 04

    Mileage : 000

    Default

    The filter could do with changing.
    Yes that is the drain hole. Give it a clean out to be on the safe side.
    With the filter out. Try pressing the front screen demist button see if the "blow" is as strong then. Or stronger. If it is stronger as it should be then it will point to a bolcked filter restricting the incoming air.

  9. #9
    Regular Member mattv6diesel's Avatar
    Join Date
    Oct 2009
    Location
    portland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Bmw 330d

    Trim : Msport

    Engine : 3.0d

    Year : 2008

    Default

    good job you cought the blocked drain

  10. #10
    Regular Member
    Join Date
    Jan 2010
    Location
    Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If I put recirc on, turn the fans up and set airflow to auto they can blow pretty fast. When I press the demist button they slow down. When I turn the demist off they speed up to what they are like on the Mrs' SRi, then slow down a little again.

    Wierd eh?

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. another climate control
    By Даниил in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 10th December 2011, 19:43
  2. Climate control and GID
    By Ben_ in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 5th October 2011, 19:30
  3. climate control
    By stu_c in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 13th December 2010, 18:27
  4. Climate control Help
    By SteveH in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 11th January 2009, 00:23
  5. Climate Control
    By liphook in forum Electrical & ICE (including SatNav)
    Replies: 9
    Last Post: 15th December 2008, 04:10

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •