User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: Fuel filter plug?

  1. #1
    New Member
    Join Date
    Jun 2009
    Location
    Kent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Fuel filter plug?

    Anyone know what the electrical plug does on the top of the fuel filter ?

  2. #2
    Admin & Merchandise Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    67 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : insignia

    Trim : irmscher

    Engine : 2.0 cdti

    Year : 2009

    Default

    I would stab at a guess its for the pumps to pump fuel out of filter house

    Irmscher Insignia CDTI 130

    MOD'S...Irmscher front spoiler, Irmscher mats, Irmscher door pins, Irmscher rear spoiler, Irmscher grille, Irmscher skirt & exhausts,Irmscher Roof spoiler MOD'S TO COME..Side skirts,Wheels

  3. #3
    Regular Member
    Join Date
    Sep 2007
    Location
    Nottinghamshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I guess that's a picture of a fuel filter on a DTI. If so, it's the connector for the fuel heater which is built into the fuel filter. The pump is a great big thing driven off the engine chain, so it's not that!

    On a CDTi, there's a similar fuel heater connector in the top of the fuel filter and also a connector for a water sensor on the side of the fuel filter. The DTI's fuel filter doesn't have a water sensor.

  4. #4
    Admin & Merchandise Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    67 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : insignia

    Trim : irmscher

    Engine : 2.0 cdti

    Year : 2009

    Default

    It was a stab in the dark should of checked my haynes manual lol

    Irmscher Insignia CDTI 130

    MOD'S...Irmscher front spoiler, Irmscher mats, Irmscher door pins, Irmscher rear spoiler, Irmscher grille, Irmscher skirt & exhausts,Irmscher Roof spoiler MOD'S TO COME..Side skirts,Wheels

  5. #5
    New Member
    Join Date
    Jun 2009
    Location
    Kent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks James24 yes mate sorry for not telling you the model 2.0 DTI been having terrible problems with the P0400 code EGR Valve flow and found that this plug was disconnected would it cause a problem with the cold we have been having?

  6. #6
    Regular Member
    Join Date
    Sep 2007
    Location
    Nottinghamshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by reesteod View Post
    Thanks James24 yes mate sorry for not telling you the model 2.0 DTI been having terrible problems with the P0400 code EGR Valve flow and found that this plug was disconnected would it cause a problem with the cold we have been having?
    It won't be helpng. The heater warms the diesel up as it passes through the filter when it's really cold, so I would image that the wiring being disconnected won't be helping either starting or running when it's cold.

    Plug it back in - which needs to be done in any case - and see what difference it makes. If it doesn't resolve the problem, then you'll have to continue your search.

  7. #7
    Regular Member jonnybravo's Avatar
    Join Date
    Jul 2009
    Location
    barnsley,yorkshire,GB
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum


    Engine : 20 Dti


    Default

    As james says plug it back in.erase codes then run engine,recheck codes if you still have 400 remove egr clean and refit.it's not a bad job on the dti

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 19
    Last Post: 30th May 2012, 15:53
  2. Random Plug Next to pollen filter???
    By Kev_G in forum Vectra C / Signum Troubleshooting
    Replies: 11
    Last Post: 26th July 2011, 10:08
  3. What Is This Plug/Connector For? (nr pollen filter)
    By ChrisBilly in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 29th April 2010, 18:43
  4. How do i remove the fuel lines from 3.2 fuel filter...?
    By killer_bunny in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 4th March 2010, 23:07
  5. Oil Filter location and Fuel Filter
    By trickydickySRI in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 26th July 2006, 10:31

Visitors found this page by searching for:

vectra c fuel filter plug

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •