User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: NO Power after 70

  1. #1
    New Member bossphillip's Avatar
    Join Date
    Nov 2009
    Location
    merseyside
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Smile NO Power after 70

    hi, i have a vectra tdi 2 lt 2004 sxi
    i was going over 70mph on the motorway the other day and felt a drop in the power and then realised the spanner warning light had come on.I stopped ,waited 5 minutes, turned the engine back on and the light went out and the engine was fine.
    When driving normal it was fine but if you needed a bit of power, it would drop again and the spanner light would come on.
    It has been ok for a couple of days with normal driving. Last night went on the motorway again, went to overtake with a bit of power and it Dropped again.
    Came of the motorway but when in 1st and 2nd gear it was as if the engine was going to cut out.
    Has anyone experienced this and do they know what it could be .Thanks

  2. #2
    Full Member paul.sessions's Avatar
    Join Date
    May 2009
    Location
    leighton buzzard
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    should you be going over 70

  3. #3
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default


  4. #4
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    You might want to have the codes read

  5. #5
    Regular Member
    Join Date
    Apr 2006
    Location
    Kingswinford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : LS

    Engine : 2.0 DTI

    Year : 2003

    Mileage : 150000

    Default

    check the vacuum hoses, I had identical problem a while ago and one of the rubber sleeves on the vacuum pipes had split.

  6. #6
    Regular Member
    Join Date
    Sep 2009
    Location
    Swindon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    When it happens does it limit you to 3000 rpm? You should get the codes read to see what it's complaining about, sounds like a boost problem.

    Frenchman

  7. #7
    New Member Adder's Avatar
    Join Date
    Feb 2010
    Location
    Lancaster
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Don't know if the 2ltr is the same as my 1.9CDTi, but with mine it's complaining that the fuel filter needs draining.

    For the cost /effort involved I usually change the filter when it starts doing it. Everything will be fine until you need a bit of extra power (usually seems to happen to me when I'm overtaking going up hill, just for extra inconvenience) then it will cut power down to what feels like about half of what it should be and the spanner lights up (first time it happend to me I was a little bit disgruntled, I've never had a car that called me a spanner before!). It does reset on turning the engine off, but will then continue to do it until I sort the filter. If it helps, I try to limit mine to less than 2.7krpm, it dosen't do it below that engine speed. It does log a code with the ecu, but isn't listed as present after you do the filter and has no ill effects.

    Hope your 2ltr is as easy to sort as mine.

  8. #8
    Regular Member suggs1971's Avatar
    Join Date
    Feb 2009
    Location
    east cleveland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had the same problem last year, got to 60-70 mph and the spanner light would come on, got my veccy on a code reader and it showed egr valve low flow. So i took the egr valve off and cleaned it, no problems since.

  9. #9
    Regular Member
    Join Date
    Dec 2009
    Location
    fife
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had the same problem it was the egr value

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 17
    Last Post: 11th March 2015, 00:55
  2. Signum Sluggish low power, Limp mode at high power.
    By Bigg943 in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 6th June 2011, 18:55
  3. Signum Sluggish low power, Limp mode at high power.
    By Bigg943 in forum Vectra C / Signum Troubleshooting
    Replies: 0
    Last Post: 5th June 2011, 11:30
  4. Replies: 11
    Last Post: 7th January 2010, 17:50
  5. Power Steering Electrical Power Drain
    By AntB in forum Suspension, Wheels & Brakes
    Replies: 5
    Last Post: 1st November 2007, 16:03

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •