User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: Rear Heated Screen Fault

  1. #1
    Regular Member
    Join Date
    Feb 2010
    Location
    South Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Rear Heated Screen Fault

    O.k so I am fslowly getting through the veccy's faults and fixing them one at a time thanks to the advice and help i've received from the guys on here, my next problem is the fact that my rear heated screen wont work....the button lights up but nothing happens to the window..........also the boot pop button doesn't open the boot it just makes a beep noise so i'm wondering if these are related faults or not and if any knows how to check these faults?? i've checked the fuses in the boot and they all seem fine for the heated screen so im lost now.

    Thanks again guys.

    Adam

  2. #2
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    All that button on the door is beep and allow the boot to open if its locked. It doesn't actually open the boot
    Now I need a turbo to keep up!

  3. #3
    Regular Member
    Join Date
    Feb 2010
    Location
    South Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    ah ok ta lol any ideas about why the key wont pop it or the window heater doesnt work??

  4. #4
    Regular Member
    Join Date
    Oct 2008
    Location
    rothwell leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : sri

    Engine : 1800 vvt

    Year : 2007

    Default

    try the fuse...get a test light and check for live and earth feeds on the connections on rear window also check for damage to rubber gaiter where tailgate hinges are

  5. #5
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The key doesn't pop it either, the button operates a solenoid. SOunds like its an electrical fault linked to the rear screen?
    Now I need a turbo to keep up!

  6. #6
    Regular Member suggs1971's Avatar
    Join Date
    Feb 2009
    Location
    east cleveland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    My rear heated screen stopped working recently. Switch would light up, heated mirrors worked but not the rear screen. I stripped all the trim off the boot and checked all the connections and wiring with a multi-meter, all checked out fine so i thought. When i checked the female connector to the spade connector to the rear screen on the passenger side it was loose so i crimped the connector which made a better fit and now the heated rear screen works. I also has an alarm check safe guard come on the display screen everytime i started the car, this has now stopped since fixing the heated rear screen.

  7. #7
    Regular Member
    Join Date
    Feb 2010
    Location
    South Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by suggs1971 View Post
    My rear heated screen stopped working recently. Switch would light up, heated mirrors worked but not the rear screen. I stripped all the trim off the boot and checked all the connections and wiring with a multi-meter, all checked out fine so i thought. When i checked the female connector to the spade connector to the rear screen on the passenger side it was loose so i crimped the connector which made a better fit and now the heated rear screen works. I also has an alarm check safe guard come on the display screen everytime i started the car, this has now stopped since fixing the heated rear screen.
    that sounds exactly like mine i'll try that hope it's that its so annoying not being able to see out of my rear screen aye!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Heated rear screen issues
    By Jonsey in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 13th January 2012, 00:30
  2. Elite Estate Rear Heated Screen
    By keefy*2010 in forum Styling
    Replies: 5
    Last Post: 27th June 2011, 15:29
  3. heated rear screen
    By gary_e in forum Troubleshooting
    Replies: 0
    Last Post: 16th November 2010, 00:01
  4. Signum Heated Rear Window Fault - WEIRD !
    By Signumv6man in forum Electrical & ICE (including SatNav)
    Replies: 9
    Last Post: 29th December 2008, 19:21
  5. Heated rear screen element repair
    By Vecmaniac in forum Electrical & ICE (including SatNav)
    Replies: 12
    Last Post: 20th January 2008, 09:22

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •