User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Odd electrical faults

  1. #1
    New Member
    Join Date
    Nov 2009
    Location
    Milton Keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Odd electrical faults

    Hi Gang

    had a few odd electrical things recently - started with cruise control not working on one journey (not repeated but I don't use it very often) ...next the CD70 won't change radio channel without being switched off first (this is intermittent and happened four or five times in the last couple of weeks) and then today, start the car and the power steering light comes on and steering very heavy - immediately switch the ignition off and it works again.

    In the last three months it's had a new alternator and then in the last six weeks the dreaded injector three problem...

    it's a 06 SRI estate 1.9CDTi 150 - 64k, owned since new

    any suggestions?

    cheers Mart

  2. #2
    Ex Vec-C Admin ed taylor's Avatar
    Join Date
    Oct 2005
    Location
    Looking Through a Camera Lens.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : Elite

    Engine : 3.2 V6

    Year : 04

    Mileage : 000

    Default

    Probably not the answer to correct the faults. But have you tried disconecting the battery for a while. You never know it might re-set things?.

  3. #3
    Regular Member westonprawn's Avatar
    Join Date
    Jul 2009
    Location
    TELFORD
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Dodgey replacement alternator/connections maybe??

  4. #4
    New Member
    Join Date
    Nov 2009
    Location
    Milton Keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks Guys

    I'll give it a go next weekend - car's due for a massive valet soon so if the weather's okay...

    MM

  5. #5
    Regular Member Danialj32's Avatar
    Join Date
    Sep 2009
    Location
    Warrington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Does the light come up on the cruise control? My clutch has a weak spring or something, when I press the button it lights up for about half a sec and goes off, I have to put my foot under the pedal and lift the pedal up and then press the cruise control button.

  6. #6
    Regular Member
    Join Date
    Sep 2009
    Location
    warwickshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hi, have you had the battery tested ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My new car faults!
    By ScottyV6 in forum Engine & Drivetrain
    Replies: 9
    Last Post: 26th September 2012, 22:09
  2. [Vectra C] [02-08] 03 sri water in foot well but now have many electrical faults
    By gavin1981 in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 16th September 2012, 21:51
  3. Electrical Faults????
    By mikemac in forum Vectra C / Signum Troubleshooting
    Replies: 0
    Last Post: 12th May 2011, 19:41
  4. Electrical Faults HELP
    By mikemac in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 12th May 2011, 18:02
  5. VEC FAULTS X2 Anybody help???
    By DonMafia in forum Introduce yourself.
    Replies: 14
    Last Post: 25th January 2009, 17:02

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •