User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: misfire on diesel

  1. #1
    Regular Member
    Join Date
    Oct 2008
    Location
    lincoln
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default misfire on diesel

    hi i have a cdti 150 & its just started misfiring. There is no loss of power just an annoying judder now & then. Its had a new manifold & swirl valves on last yr. When it misses theres no smoke or funny noises any ideas please

  2. #2
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    do a search for the 3rd injector plug fault, that could be your problem

  3. #3
    Regular Member
    Join Date
    Oct 2008
    Location
    lincoln
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks

  4. #4
    Regular Member Matty777's Avatar
    Join Date
    Jan 2010
    Location
    Nr Maidstone
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Not an expert but could it be the MAF sensor? Mine went a bit like that but this was a B 2.0DTi. They can be cleaned with carb cleaner, but it was temporary and needed a new MAF in the end.

  5. #5
    New Member
    Join Date
    Jun 2009
    Location
    Northern Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    My car did the same, it was very random at first but then it started happening all the time. Vx couldn't see anything wrong for a couple of weeks, they changed the egr but it wasn't that in the end they changed a throttle sensor which fixed the problem. Apparently the sensor sits in the throttlebody somewhere.

  6. #6
    Regular Member
    Join Date
    Oct 2009
    Location
    Teesside
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Does it do it more @ 1800 revs (test if you haven't noticed)

    But defo sounds like the 3rd injector plug issue.

    Goto the how to section and in there it tells you how to fix it for £12

  7. #7
    Regular Member P3tchy's Avatar
    Join Date
    Jan 2009
    Location
    Milton Keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mine does it, Did the 3rd injector..... Still does it.

    Goes in next week for new manifold, Actuator, intercooler, EGR strip and rebuild with fiat blanking plate added If none of that cures it then whats another £5 for a can of petrol.

  8. #8
    Regular Member
    Join Date
    Oct 2008
    Location
    lincoln
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yes its worse under load already got new manifold, swirl valves and egr fitted last year under warranty. Will look into 3rd injector tommorow

  9. #9
    Regular Member
    Join Date
    Oct 2008
    Location
    lincoln
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    All sorted now it was the wiring on injectors not sure which 1 thanks for info

  10. #10
    Regular Member P3tchy's Avatar
    Join Date
    Jan 2009
    Location
    Milton Keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Did you do all of them then? I only changed the 3rd from the left (looking at the engine) and it still does it, plus my MPG has gone down loads.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Slight diesel leak from Diesel filter housing :-(
    By rollercoaster63 in forum Engine & Drivetrain
    Replies: 1
    Last Post: 22nd July 2015, 21:18
  2. misfire on 1.8
    By Lozza in forum Engine & Drivetrain
    Replies: 14
    Last Post: 9th August 2012, 23:57
  3. "Misfire" At 1800k On 1.9 Diesel?
    By Marc D in forum Vectra C / Signum Troubleshooting
    Replies: 3
    Last Post: 14th June 2012, 16:52
  4. BP Ultimate Diesel vs Morrison's mucky Diesel
    By Big Knox in forum General Chat
    Replies: 5
    Last Post: 31st March 2009, 13:11
  5. Shell Diesel Extra Or BP Ultimax Diesel
    By tonyx420 in forum Vectra C / Signum Car Chat
    Replies: 24
    Last Post: 11th July 2007, 13:25

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •