User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: Blower Motor Fault...With a Difference!

  1. #1
    Regular Member cphaza's Avatar
    Join Date
    Sep 2008
    Location
    Hertfordshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Blower Motor Fault...With a Difference!

    Bit of a funny one here. Heater motor blew (and resistor) recentley, full of water. Blagged another one of each from the scrappers for £30 and fitted up. However, now I have speeds 1 and 4 only, and it wont turn off! By that i mean that when you switch down from speed 4 (which works normally) every other setting just blows at speed 1, including when you turn the begger off!

    I'm guessing its a dodgey switch pannel, but just seems a bit of a coincidence for them both to go at the same time so figured i'd throw it up here to see if anyone has any bright ideas!
    Cheers
    Chris

  2. #2
    Regular Member cphaza's Avatar
    Join Date
    Sep 2008
    Location
    Hertfordshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Sorry, not sure how i managed to post this twice, t'ut internet playing up! Can admin remove this thread, ta.

  3. #3
    Regular Member cphaza's Avatar
    Join Date
    Sep 2008
    Location
    Hertfordshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default


  4. #4
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Default

    Use the report post button to flag it up to a moderator.

  5. #5
    Regular Member cphaza's Avatar
    Join Date
    Sep 2008
    Location
    Hertfordshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    its ok, they deleted the other one (somehow started two threads!) Was more of a bump for info on the problem. Got me a bit foxed!

  6. #6
    Regular Member cphaza's Avatar
    Join Date
    Sep 2008
    Location
    Hertfordshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    anyone any ideas? Dont have another switch pannel to try at the moment as the mrs is away but with the other vec

  7. #7
    Regular Member Ste's Avatar
    Join Date
    Jul 2005
    Location
    ..... Driving the Jaguar XF
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Have a look at the wiring diagram

    http://www.vectra-c.com/forum/upload...010/Heater.JPG

    and check the voltages into the resistor pack. Position one will put power through all 3 resistors and position 3 only through one resistor. Position 4 operates the relay K5.

    Should be fairly easy to see if it is the switch pack that is defective.

    If it is the switch panel, I would have thought that it could be repaired without too much trouble - maybe just dirty contacts?

  8. #8
    Regular Member cphaza's Avatar
    Join Date
    Sep 2008
    Location
    Hertfordshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    cheers mate, havent studied a wiring diagram (must bite the bullet and get a haynes - they are good for some things!) but will do so tomorow. the fact that its always on when ignition is live makes me think switch, or relay of course.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Changing the blower motor?
    By kangakev in forum Electrical & ICE (including SatNav)
    Replies: 12
    Last Post: 31st January 2014, 19:11
  2. Blower Motor?
    By steve533 in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 6th October 2012, 22:00
  3. Vec C Blower Motor
    By AntSSSS in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 31st December 2010, 17:24
  4. help heater blower motor
    By whitevanman in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 5th December 2010, 01:27
  5. Blower motor
    By Butler in forum Bodywork & Interior
    Replies: 0
    Last Post: 13th January 2009, 09:47

Visitors found this page by searching for:

Www.vectra 2.0 wiring diagram

vauxhall vectra c wiring diagram

vauxhall vectra electrical scheme

vectra c sähkökuvat

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •